2004 Impala A.C. problem - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Performance and Technical > Mechanical and Electrical Problems

Mechanical and Electrical Problems Having problems with your Chevy Impala? Discuss it here.

Reply
 
LinkBack Thread Tools Display Modes
Old 05-28-2012, 05:49 PM   #1 (permalink)
Senior Member
 
Raider's Avatar
 
Join Date: May 2012
Posts: 172
Thanks: 4
Thanked 4 Times in 4 Posts
2004 Impala A.C. problem

Today when I started my car the A.C. will not blow air. I try every setting, I even tried heat and defroster. The lights come on the switch but no air at all. Then after 10 minutes of driving it starts blowing cold air. anyone have any ideas ?

Raider is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-28-2012, 07:03 PM   #2 (permalink)
Member
 
Ray2138's Avatar
 
Join Date: May 2012
Location: NC/VA
Posts: 32
Thanks: 3
Thanked 2 Times in 2 Posts
Have you checked your blower motor relays ,fuses , or any other possibilities ?

Ray2138 is offline   Reply With Quote Quick reply to this message
Old 05-29-2012, 04:05 AM   #3 (permalink)
Senior Member
 
Raider's Avatar
 
Join Date: May 2012
Posts: 172
Thanks: 4
Thanked 4 Times in 4 Posts
Relay and fuse are good. It only does this every once in a while then it goes on after about 5-10 minutes of driving. I may have a bad connection at the blower motor maybe

Raider is offline   Reply With Quote Quick reply to this message
Old 06-20-2012, 05:42 PM   #4 (permalink)
Junior Member
 
alapmi9's Avatar
 
Join Date: Jun 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
fan blower/cruise light/message center

My 02 has this same problem. When this problem occurs the cruise light comes on and the message center is blank and the fan blower does not work. I have done a lot of online research and what I have found is that many other people have solved this problem by replacing the ignition switch. Many of them have taken their problem to dealer and as usual the dealer can fix problem for $500 or more. The dealer never mentions the $100 ignition switch but replaces other high $ parts. I wonder if they know the problem? Anyway I have yet to try this fix. I intend to do it this weekend. I'll let you know if I am successful or not.

alapmi9 is offline   Reply With Quote Quick reply to this message
Old 06-21-2012, 08:15 AM   #5 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,660
Thanks: 516
Thanked 1,191 Times in 787 Posts
Thats bizarre, I'd be interested to hear if that fixes it or not. Luckily the ignition switch is pretty easy to replace in these.

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Old 06-24-2012, 07:26 AM   #6 (permalink)
Junior Member
 
alapmi9's Avatar
 
Join Date: Jun 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
I was not able to do this because I had to work. Also I din't think its that easy. The process that I read seems to entail a lower dashboard teardown. Do you know an easier way to do this?

alapmi9 is offline   Reply With Quote Quick reply to this message
Old 06-24-2012, 07:38 AM   #7 (permalink)
Junior Member
 
alapmi9's Avatar
 
Join Date: Jun 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
I don't know if this is allowed but here is a link from another forum concerning this problem. I think it shows that this is not an isolated problem.

2002 Impala Cruise light on Heater Fan Off - Topix

alapmi9 is offline   Reply With Quote Quick reply to this message
Old 06-25-2012, 11:50 AM   #8 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,660
Thanks: 516
Thanked 1,191 Times in 787 Posts
It only takes a couple minutes to take out the lower dash

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Old 07-08-2012, 01:43 PM   #9 (permalink)
MiX
Member
 
MiX's Avatar
 
Join Date: Sep 2009
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
did the ignition switch fix the problem?

__________________
palyred
MiX is offline   Reply With Quote Quick reply to this message
Old 07-28-2012, 10:31 AM   #10 (permalink)
Junior Member
 
Bandit's Avatar
 
Join Date: Jul 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by alapmi9 View Post
My 02 has this same problem. When this problem occurs the cruise light comes on and the message center is blank and the fan blower does not work. I have done a lot of online research and what I have found is that many other people have solved this problem by replacing the ignition switch. Many of them have taken their problem to dealer and as usual the dealer can fix problem for $500 or more. The dealer never mentions the $100 ignition switch but replaces other high $ parts. I wonder if they know the problem? Anyway I have yet to try this fix. I intend to do it this weekend. I'll let you know if I am successful or not.
Hi! Did you finish ignition switch replacement? Please let me know, because I have the same problem. Do you have part number for ignition switch?
Thank You

Bandit is offline   Reply With Quote Quick reply to this message
Old 07-30-2012, 10:45 AM   #11 (permalink)
Senior Member
 
ChevroletCustomerService's Avatar
 
Join Date: Nov 2010
Posts: 866
Thanks: 1
Thanked 50 Times in 38 Posts
Please add my name to the list of users who would love an update on the switch replacement results, if possible!

Bandit, direct message me anytime if you'd like me to investigate your concerns further.

Best,

Katie
Chevrolet Customer Service

ChevroletCustomerService is online now   Reply With Quote Quick reply to this message
Old 07-31-2012, 04:31 PM   #12 (permalink)
Junior Member
 
alapmi9's Avatar
 
Join Date: Jun 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by MiX View Post
did the ignition switch fix the problem?
yes it did took about four hour to tear down the dash to get to it that includes a couple of beer breaks and a run to pick up new ignition switch

alapmi9 is offline   Reply With Quote Quick reply to this message
Old 07-31-2012, 04:33 PM   #13 (permalink)
Junior Member
 
alapmi9's Avatar
 
Join Date: Jun 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Bandit View Post
Hi! Did you finish ignition switch replacement? Please let me know, because I have the same problem. Do you have part number for ignition switch?
Thank You
it worked got part from advance auto parts $85
all you need is the switch not the key part

alapmi9 is offline   Reply With Quote Quick reply to this message
Old 07-31-2012, 04:38 PM   #14 (permalink)
Junior Member
 
alapmi9's Avatar
 
Join Date: Jun 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by ChevroletCustomerService View Post
Please add my name to the list of users who would love an update on the switch replacement results, if possible!

Bandit, direct message me anytime if you'd like me to investigate your concerns further.

Best,

Katie
Chevrolet Customer Service
Replacing the ignition switch fixed the problem. I'm still baffaled that the three problems seem so prevelent and yet the dealers don't seem to know about this fix

alapmi9 is offline   Reply With Quote Quick reply to this message
Old 07-31-2012, 04:40 PM   #15 (permalink)
Junior Member
 
alapmi9's Avatar
 
Join Date: Jun 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by kingnutin View Post
It only takes a couple minutes to take out the lower dash
took about 180 minutes and it fixed the problem

alapmi9 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 impala ls wiper problem impalaboy2004 Chevy Impala 7th Gen Discussion 0 05-06-2011 06:40 AM
2004 Impala - Strange Problem FLImpaladriver Mechanical and Electrical Problems 6 11-01-2008 11:52 AM
Problem with my 2004 Chevy Impala...can you help? Mr. D Mechanical and Electrical Problems 4 09-30-2008 11:34 AM
Problem with 2004 Impala. Can you help....? Mr. D Mechanical and Electrical Problems 1 12-14-2007 05:22 AM
Problem with 2004 Chevy Impala...can you help? Mr. D Mechanical and Electrical Problems 3 12-12-2007 11:20 AM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.