2006 Impala SS - Hood open light - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Performance and Technical > Mechanical and Electrical Problems

Mechanical and Electrical Problems Having problems with your Chevy Impala? Discuss it here.

Reply
 
LinkBack Thread Tools Display Modes
Old 07-24-2009, 07:37 AM   #1 (permalink)
Junior Member
 
butcher11's Avatar
 
Join Date: Jul 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
2006 Impala SS - Hood open light

Hi,

I have probably a very simple but annoying problem on my Impala. The Hood open light is on in the dash cluster. Can someone direct me to where the switch actually is under the hood? I couldn't find it.

Thanks
Eric

butcher11 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-27-2009, 02:09 PM   #2 (permalink)
Senior Member
 
blusail's Avatar
 
Join Date: Oct 2008
Location: WINSTON SALEM, NC
Posts: 416
Thanks: 0
Thanked 0 Times in 0 Posts
The hood ajar switch is part of the latch assy. mounted on the the front radiator support brace.

blusail is offline   Reply With Quote Quick reply to this message
Old 08-08-2009, 09:25 AM   #3 (permalink)
Junior Member
 
butcher11's Avatar
 
Join Date: Jul 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for that info!

I undid the plug, cleaned everything that I could and still that darn light stay on. I looked at the plug and thought maybe I can just jump it and make the light stay off. Problem is it has three wires.

Anyone know how to jump the wire so that dash light never comes on again. I can't seem to make myself pay any money for something like this on a car and don't really want it to come back.

Thanks

butcher11 is offline   Reply With Quote Quick reply to this message
Old 08-08-2009, 04:22 PM   #4 (permalink)
Senior Member
 
capricewiz's Avatar
 
Join Date: Apr 2008
Location: Doylestown, PA
Posts: 556
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via AIM to capricewiz
yeah, replace the latch, if you have remote start, it won't work if the hood ajar switch doesn't work just keep it in mind

capricewiz is offline   Reply With Quote Quick reply to this message
Old 07-26-2010, 11:10 AM   #5 (permalink)
Junior Member
 
dragntat2's Avatar
 
Join Date: Jul 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
I have the same issue with mine, and then some. Started yesterday with it saying "hood open", but it's not.....went to start the car, DEAD, noticed radio was on though. So the car appears to be stuck in accessory mode when off/keys out.....you can roll the windows up and down and everything. After having it jumped, now it also (in additon to hood open) says calibration complete, the turning signals don't work, high beams don't work, trunk button (interior) does not work etc....I don't know what to do!

dragntat2 is offline   Reply With Quote Quick reply to this message
Old 07-26-2010, 02:00 PM   #6 (permalink)
Carpe Diem


 
donmateo's Avatar
 
Join Date: Aug 2009
Location: Racine, WI
Posts: 19,098
Thanks: 1,994
Thanked 1,714 Times in 1,168 Posts
Send a message via MSN to donmateo Send a message via Skype™ to donmateo
Did you check to see if the hood WAS open? lol

__________________
www.basilonestopshop.com
Basil One-Stop Shop BBM Channel: C00120B93
Basil One-Stop Shop BBM Customer Service Chat Available
donmateo is online now   Reply With Quote Quick reply to this message
Old 08-09-2012, 04:10 AM   #7 (permalink)
Junior Member
 
stunna08's Avatar
 
Join Date: Aug 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by dragntat2 View Post
I have the same issue with mine, and then some. Started yesterday with it saying "hood open", but it's not.....went to start the car, DEAD, noticed radio was on though. So the car appears to be stuck in accessory mode when off/keys out.....you can roll the windows up and down and everything. After having it jumped, now it also (in additon to hood open) says calibration complete, the turning signals don't work, high beams don't work, trunk button (interior) does not work etc....I don't know what to do!
Question did u ever get this problem fix my car is doing the same exacte thing, dont know what to do....Thanks

stunna08 is offline   Reply With Quote Quick reply to this message
Old 08-10-2012, 07:58 AM   #8 (permalink)
Senior Member
 
ChevroletCustomerService's Avatar
 
Join Date: Nov 2010
Posts: 871
Thanks: 1
Thanked 51 Times in 39 Posts
Stunna08, if you don't receive a lot of replies I would suggest starting a new thread to try to generate more community responses. And please send me a direct message anytime with the last eight of your VIN if you'd like me to investigate for you!

Best,

Katie
Chevrolet Customer Service

ChevroletCustomerService is online now   Reply With Quote Quick reply to this message
Old 08-10-2012, 09:01 AM   #9 (permalink)
TSS
Administrator

 
TSS's Avatar
 
Join Date: Mar 2010
Location: Michigan
Posts: 8,824
Thanks: 520
Thanked 923 Times in 508 Posts
No. /\

Please do not start a new thread. You did exactly the right thing by searching. THANK YOU! This way, there are not redundant responses for exactly the same question. By posting on this thread, you brought it back to the top.

__________________
2009 Impala SS (sold 3/2012);
2010 Buick Enclave CXL;
2010 Lincoln MKS AWD Twin Turbo, Livernois Motor Sports tuned, K&N Typhoon CAI, 0-60 in 4.20 seconds , 1/4 mile 12.80 @ 104 MPH



"Trying Times Are Not a Good Time To Quit Trying"
TSS is offline   Reply With Quote Quick reply to this message
Old 08-10-2012, 10:07 AM   #10 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,656
Thanks: 516
Thanked 1,192 Times in 788 Posts
Kinda sounds like a BCM issue, that's the only common factor I can think of with all those things.

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Old 03-24-2014, 08:16 PM   #11 (permalink)
Junior Member
 
sphillips's Avatar
 
Join Date: Jul 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Old thread, but I had the same issue. Tried cleaning the contacts but that did not fix it. Called Chevy, they wanted I think $160 for the latch assy which is the only way to get a switch. Found the assy on EBay for $39, installed it in 15min and fixed the problem!

sphillips is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://www.impalaforums.com/mechanical-and-electrical-problems/240058-2006-impala-ss-hood-open-light.html
Posted By For Type Date
1965 IMPALA FOR SALE- NOT SS (Watsonville) $6000 - 1963 Impala For Sale This thread Refback 05-14-2012 08:41 AM

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Impala Hood Open Light suspension325 Automotive Discussion 5 02-06-2010 08:26 PM
how do you open the box in the Impala on the supernatural web site? keitaya Chevy Impala Discussion 0 06-14-2008 10:48 AM
My 2008 Impala trunk won't open? Lee G Chevy Impala Discussion 10 04-30-2008 08:33 PM
Hi, I can't get the hood open on my 2000 Chevy Impala. The release won't work? letsplay200650 Chevy Impala Discussion 1 04-10-2008 04:34 PM
my 1990 cadillac fleetwood battery died and I cant get the hood open now...help!? Lance Buick Roadmaster 2 11-06-2007 07:11 AM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.