Forum login is not secure (not news, but the browser complains now) - Chevy Impala Forums
Impala Forum Site Issue Forum Post any questions, concerns, and issues you are having with the site that need to be resolved.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-13-2017, 12:42 PM Thread Starter
Senior Member
 
bignick2015's Avatar
 
Join Date: Dec 2014
Posts: 214
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Thanks: 10
Thanked 27 Times in 18 Posts
Forum login is not secure (not news, but the browser complains now)

With a recent upgrade to Firefox, it now displays warnings when typing in username and password that this site is not secure.

I've known this for a while, and I have again manually tried https://www.impalaforums.com/ and it does not work.

Is https support in the works for a future forum upgrade?

2015 Crystal Red Impala LTZ V6
2013 Summit White Impala LT

bignick2015 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 05-13-2017, 01:09 PM
Administrator

 
retiredpauly's Avatar
 
Join Date: Jan 2012
Location: Cochrane Alberta Canada
Posts: 9,826
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 113 Post(s)
Thanks: 1,316
Thanked 2,319 Times in 1,333 Posts
As far as I know all they were doing was something to change some vendor protocols and rules. Not sure that would cause what your taking about.
Maybe take a screen shot of the screen warning you get and post it here and they will no doubt respond at some point.
Just wondering if Firefox is reponidng to latest cyber thing that's happening. ??? Shrug......dunno.
I have not had an issue or any warnings so far.

Some things are better left unsaid, which I generally realize right after I have said them.
retiredpauly is offline  
post #3 of (permalink) Old 05-15-2017, 08:37 AM
Helena
 
Admin's Avatar
 
Join Date: Jan 2011
Posts: 450
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Thanks: 38
Thanked 156 Times in 73 Posts
Garage
Https will be added to the site in the near future, though I don't have an official ETA yet. Mostly HTTPs protects against MIM attacks (man in the middle) where someone intercepts what you are typing as you type it, not something that is super useful on a site where most everything is being posted to a public forum readable by anyone. Still, it's been on the "to-do" list for awhile now. Firefox is making us push it up higher on that list though.

Kevin

If you need admin support post here:
http://www.impalaforums.com/impala-f...e-issue-forum/
Admin is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Good news and bad news Jomaba4308 Automotive Discussion 0 08-06-2016 11:05 AM
Last login : 12-17-2008 Slow Chevy Media Bucket 27 03-30-2012 11:55 AM
What browser do you guys use? Richard Off-Topic Discussion 68 05-12-2008 12:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome