1963 wiring problems maybe - Chevy Impala Forums
Impala 1st - 5th Gen Discussion 1958-1985. Discuss all Chevy Impala 1st Gen - 5th Generation Performance and Technical Discussion here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-26-2012, 05:43 PM Thread Starter
Junior Member
 
bigmanvoodoo's Avatar
 
Join Date: Jul 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
1963 wiring problems maybe

i recently bought a 1963 Impala 2 door. i got it home and started checking things over and well motor Check, brakes check, windows check, brake lights...errr uh oh. i had one brake light so i started i noticed some corrosion on the sockets no biggy to fix. got that taken care of. then i noticed that the drivers side are much dimmer than the passenger side. hit the blinkers and nothing. turn headlights off and i got blinkers. go to turn the head lights back on and nothing. wiggle the knob( ha ha) and i get lights. long story short could my head light switch be causing the problem?
bigmanvoodoo is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 07-26-2012, 06:48 PM
Back in Black
 
12ltz's Avatar
 
Join Date: Apr 2012
Location: Manassas or Suffolk,Va
Posts: 4,118
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 103
Thanked 228 Times in 159 Posts
Sounds like it to me or at least check wiring on back of switch.
12ltz is offline  
post #3 of (permalink) Old 07-26-2012, 07:05 PM
Storm Trooper Ralf
 
MixedImpala04's Avatar
 
Join Date: May 2011
Location: merced, CA
Posts: 4,335
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 258
Thanked 342 Times in 266 Posts
Omg I hope you don't have the same prob i had on my 65, on the steering column there is a switch, check. For all your power functions there, if you don't have power their where you are supposed to change the switch, if everything is good go to the tail lights and check all the connections. I can take a picture of the switch on the steering column if you like but you should be able to see it, its got like eight wires coming out of it.
MixedImpala04 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  LinkBacks (?)
LinkBack to this Thread: http://www.impalaforums.com/impala-1st-5th-gen-discussion/328375-1963-wiring-problems-maybe.html
Posted By For Type Date
Chevy Impala Forums This thread Refback 07-26-2012 08:16 PM

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 impala wiring problems randman26 Audio, Video, and Electronics 8 11-14-2012 07:37 AM
62 Bel Air wiring problems (Tail lights or Head light swtich) slammedtoys Chevy Bel Air 3 11-11-2011 10:23 PM
Rear wiring harness 1963 Belair gtaylor Restoration Forum 2 02-14-2011 08:04 AM
Heating Problems/Cd Problems ethelaugg Chevy Impala Discussion 0 01-14-2009 08:03 AM
Wiring Classic1 Automotive Discussion 3 09-21-2008 12:14 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome