Rear Defroster Not working - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Vehicle-Specific B-Body Discussion > Chevy Impala Discussion

Chevy Impala Discussion Discuss all non-technical general Chevy Impala topics here.

Reply
 
LinkBack Thread Tools Display Modes
Old 11-19-2012, 12:03 PM   #1 (permalink)
Junior Member
 
Chevy08's Avatar
 
Join Date: Oct 2012
Location: Maine
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rear Defroster Not working

I have a 2008 LT and the rear defroster don't work.I have read allot of threads on here and still cant find what is wrong.I Have 12 volts at the positive tab when disconnected from tab on window to car ground.When I take both tabs off the grid I also have volts across the 2 tabs.When I hook them back up I get NO voltage on the grid (From Positive tab to all of the grid.) I have continuity from tabs to grid (Tabs secure to window) and all across the grid I have continuity.I hooked up a temporary ground wire to negative tab on window and nothing.When I disconnect the negative wire completely I have voltage at positive wire to ground.As soon as I hook wire back to neg tab I get no voltage from positive tab to ground or to anywhere on the grid? Thank you for any help.

Chevy08 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-20-2012, 10:07 AM   #2 (permalink)
Member
 
fixxxer's Avatar
 
Join Date: Jul 2010
Location: Iowa
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
this is a HUGE help and will most likely solve your problem


http://www.impalaforums.com/diy-how-...-write-up.html

__________________
'06 SS Impala
fixxxer is offline   Reply With Quote Quick reply to this message
Old 11-20-2012, 10:25 AM   #3 (permalink)
Senior Member
 
ChevroletCustomerService's Avatar
 
Join Date: Nov 2010
Posts: 886
Thanks: 1
Thanked 55 Times in 43 Posts
Was that link helpful, Chevy08? While we Customer Service representatives are not able to provide much in the way of do-it-yourself information, I hope that you received some great feedback from the forum. If you have any questions about recalls or warranty information, or wanted our assistance in locating and working with a dealership, please send me a direct message anytime.

Katie
Chevrolet Customer Service

ChevroletCustomerService is offline   Reply With Quote Quick reply to this message
Old 11-29-2012, 05:41 PM   #4 (permalink)
463
Senior Member
 
463's Avatar
 
Join Date: Mar 2011
Location: Sask Canada
Posts: 1,216
Thanks: 8
Thanked 72 Times in 58 Posts
http://www.impalaforums.com/chevy-im...dont-work.html

__________________
Welcome to the forum
463 is offline   Reply With Quote Quick reply to this message
Old 05-06-2013, 06:14 PM   #5 (permalink)
Junior Member
 
FirstImpala's Avatar
 
Join Date: May 2013
Location: Georgia
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks

Thanks for the link. Bought my first Chevy in 2010. Went with an 09 Impala. Dad just traded in his 03 with over 200K on it. Liked the older body style better but hey, Dad loved his so what the heck.

This past month both the actuator and rear defrost went out. Between the woodpecker living in the dashboard and not being able to see out the back window, I've been frustrated to say the least! Just tackled the actuator tonight. Thank heavens for my handy husband. He used it to teach our newly licensed son how to do repairs. I guess we will tackle the defroster this weekend!

FirstImpala is offline   Reply With Quote Quick reply to this message
Old 10-23-2013, 12:32 AM   #6 (permalink)
Junior Member
 
fosterdavin's Avatar
 
Join Date: Oct 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for the tip. My defroster works just fine now and it only took 20 minutes to fix and most importantly it was free.

fosterdavin is offline   Reply With Quote Quick reply to this message
Old 10-23-2013, 02:31 PM   #7 (permalink)
Carpe Diem


 
donmateo's Avatar
 
Join Date: Aug 2009
Location: Racine, WI
Posts: 19,842
Thanks: 2,296
Thanked 1,873 Times in 1,274 Posts
Send a message via MSN to donmateo Send a message via Skype™ to donmateo
Glad to hear the defroster problem is being fixed by so many!

To our new members, welcome!

__________________
www.basilonestopshop.com
Basil One-Stop Shop BBM Channel: C00120B93
Basil One-Stop Shop BBM Customer Service Chat Available
donmateo is offline   Reply With Quote Quick reply to this message
Old 10-23-2013, 04:18 PM   #8 (permalink)
Senior Member
 
Dave_N's Avatar
 
Join Date: Jul 2012
Location: Mississauga
Posts: 656
Thanks: 124
Thanked 55 Times in 51 Posts
Its an easy fix. Just cut the wires from the harness and clamp them together. Seal it up properly too and tape it up.

__________________
2006 Impala LTZ/SS 3.9 L V6

Magnaflow Catback Exhaust
5 Piece Billet Aluminum Grille
Chrome Side Pillars
K&N High Flow Air Filter with modified airbox
Monroe Quick Struts, 35% Window Tints
GM Strut Tower Brace Bars and Don Rome Brackets
Leather Steering Wheel Cover, Mud Flaps
Chrome Licence Plate Protectors, SS Badges
Motomaster Eliminator Battery (925 CCA)
Overkilled!
Dave_N is offline   Reply With Quote Quick reply to this message
Old 11-04-2013, 05:24 PM   #9 (permalink)
Junior Member
 
Cavalyr's Avatar
 
Join Date: Nov 2013
Posts: 3
Thanks: 0
Thanked 2 Times in 1 Post
can someone direct me to the actuator thread please? need to fix that on my Impala as well. thanks.

__________________
2008 Impala SS V8
Just about hit 100K miles
4Nov2013
Cavalyr is offline   Reply With Quote Quick reply to this message
Old 11-05-2013, 03:21 PM   #10 (permalink)
Senior Member
 
imandyyornot's Avatar
 
Join Date: Dec 2011
Location: Brooklyn NY
Posts: 258
Thanks: 13
Thanked 29 Times in 18 Posts
Send a message via AIM to imandyyornot
Quote:
Originally Posted by Cavalyr View Post
can someone direct me to the actuator thread please? need to fix that on my Impala as well. thanks.
http://www.impalaforums.com/chevy-im...tor-check.html
http://www.impalaforums.com/diy-how-...-door-fix.html
http://www.impalaforums.com/chevy-im...oor-issue.html

__________________
Anyone From The NYC Area? Lets Meet Up.

06 Impala LS
imandyyornot is offline   Reply With Quote Quick reply to this message
Old 12-17-2013, 10:27 AM   #11 (permalink)
Junior Member
 
Minkia's Avatar
 
Join Date: Dec 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by FirstImpala View Post
Thanks for the link. Bought my first Chevy in 2010. Went with an 09 Impala. Dad just traded in his 03 with over 200K on it. Liked the older body style better but hey, Dad loved his so what the heck.

This past month both the actuator and rear defrost went out. Between the woodpecker living in the dashboard and not being able to see out the back window, I've been frustrated to say the least! Just tackled the actuator tonight. Thank heavens for my handy husband. He used it to teach our newly licensed son how to do repairs. I guess we will tackle the defroster this weekend!
How did you fix the woodpecker noise in the dash mine is doing the same thing driving me crazy

Minkia is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear Defroster the blur Chevy Impala 6th Gen Discussion 1 01-28-2011 01:21 PM
rear fog defroster wont work rajeshshivam Mechanical and Electrical Problems 0 01-29-2010 02:33 PM
rear defroster Carnegie Chevy Impala 7th Gen Discussion 4 01-12-2010 08:51 AM
Non-working Rear Defroster monzaspyder Chevy Impala 8th Gen Discussion 1 11-22-2009 02:04 PM
04 rear defroster breaker SPECTRE184 Chevy Impala 7th Gen Discussion 3 03-25-2008 12:19 PM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.