Clicking noise coming from glove compartment - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Vehicle-Specific B-Body Discussion > Chevy Impala Discussion

Chevy Impala Discussion Discuss all non-technical general Chevy Impala topics here.

Reply
 
LinkBack Thread Tools Display Modes
Old 10-25-2012, 05:11 AM   #1 (permalink)
Junior Member
 
black-magic07's Avatar
 
Join Date: Aug 2012
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Clicking noise coming from glove compartment

Hello guys, I have a 2007 Chevy impala ss. I am getting a clicking noise from my glove compartment box. Everytime I crank my car its starts clicking then after 30 seconds or so, it stops. And it will sometime start clicking again when I change the climate control from cold to hot. What can this be? Any suggestions?

Sent from my ADR6425LVW using AutoGuide.Com Free App

black-magic07 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-25-2012, 05:40 AM   #2 (permalink)
Divine Autosound
 
C.E.Divine's Avatar
 
Join Date: Aug 2011
Location: Fayetteville, AR
Posts: 2,170
Thanks: 0
Thanked 8 Times in 8 Posts
Blend door actuator. Put it on cold and then wait for the clicking to stop, then turn on recirculate to see if it begins clicking again. If it doesn't, your center afire actuator has gone bad. If it clicks when you hit recirculate, your inlet air actuator has gone bad.

C.E.Divine is offline   Reply With Quote Quick reply to this message
Old 10-25-2012, 06:16 AM   #3 (permalink)
TSS
Super Moderator

 
TSS's Avatar
 
Join Date: Mar 2010
Location: Michigan
Posts: 8,465
Thanks: 362
Thanked 737 Times in 402 Posts
Do a search too - there is a write up on how to fix it your self...I belive it may even be a sticky.

__________________
2009 Impala SS (sold 3/2012);
2010 Buick Enclave CXL;
2010 Lincoln MKS AWD Twin Turbo, Livernois Motor Sports tuned, K&N Typhoon CAI, 0-60 in 4.20 seconds , 1/4 mile 12.80 @ 104 MPH



"Trying Times Are Not a Good Time To Quit Trying"
TSS is offline   Reply With Quote Quick reply to this message
Old 10-25-2012, 08:42 PM   #4 (permalink)
Junior Member
 
black-magic07's Avatar
 
Join Date: Aug 2012
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Ok I appreciate the information will try this out in the morning and let u guys know what happens

Sent from my ADR6425LVW using AutoGuide.Com Free App

black-magic07 is offline   Reply With Quote Quick reply to this message
Old 10-26-2012, 07:35 AM   #5 (permalink)
TSS
Super Moderator

 
TSS's Avatar
 
Join Date: Mar 2010
Location: Michigan
Posts: 8,465
Thanks: 362
Thanked 737 Times in 402 Posts
Here is some general info on actuators I just posted on another forum for my non-chevy - the photos might help you to undertsand the underlying issues, and the part. I had no idea what an actuator looked like until I dove into this last night.

I am still under warranty, but did not want the hassle of bringing the car to the dealer and returning to stock. Again, the actual directions are not applicable to the Impala, but the concept is. Hope it helps in some way.
Replacing Blend Door Actuator Instructions

__________________
2009 Impala SS (sold 3/2012);
2010 Buick Enclave CXL;
2010 Lincoln MKS AWD Twin Turbo, Livernois Motor Sports tuned, K&N Typhoon CAI, 0-60 in 4.20 seconds , 1/4 mile 12.80 @ 104 MPH



"Trying Times Are Not a Good Time To Quit Trying"
TSS is offline   Reply With Quote Quick reply to this message
Old 10-26-2012, 08:05 AM   #6 (permalink)
Junior Member
 
black-magic07's Avatar
 
Join Date: Aug 2012
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
I did what u said, I put it on cold then I pushed the recirculate button a few seconds later the click started. Then like 30 seconds later it stopped. The clicking noise doesn't click everytime, it usually clicks when I start the car up. It will do it like once a day. Or sometimes not at all

Sent from my ADR6425LVW using AutoGuide.Com Free App

black-magic07 is offline   Reply With Quote Quick reply to this message
Old 10-26-2012, 09:26 AM   #7 (permalink)
TSS
Super Moderator

 
TSS's Avatar
 
Join Date: Mar 2010
Location: Michigan
Posts: 8,465
Thanks: 362
Thanked 737 Times in 402 Posts
It is your blend door actuator - trust us. Very common not only in Impalas but all newer cars - did you look at the cheap plastic inner parts in the link I posted above? Disgraceful.....

__________________
2009 Impala SS (sold 3/2012);
2010 Buick Enclave CXL;
2010 Lincoln MKS AWD Twin Turbo, Livernois Motor Sports tuned, K&N Typhoon CAI, 0-60 in 4.20 seconds , 1/4 mile 12.80 @ 104 MPH



"Trying Times Are Not a Good Time To Quit Trying"
TSS is offline   Reply With Quote Quick reply to this message
Old 10-26-2012, 11:12 AM   #8 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,649
Thanks: 512
Thanked 1,180 Times in 780 Posts
Why do car companies feel a constant need to take something that works, and ruin it? It's not like they advanced the technology any, they're just trying to see how cheap they can get away with making everything. I'm thankful every day that I have an old car...

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Old 10-26-2012, 02:23 PM   #9 (permalink)
TSS
Super Moderator

 
TSS's Avatar
 
Join Date: Mar 2010
Location: Michigan
Posts: 8,465
Thanks: 362
Thanked 737 Times in 402 Posts
I agree. We haven't had any issues with the actuator in our 2001 SLS It works perfectly. They obviously cheapened the parts

__________________
2009 Impala SS (sold 3/2012);
2010 Buick Enclave CXL;
2010 Lincoln MKS AWD Twin Turbo, Livernois Motor Sports tuned, K&N Typhoon CAI, 0-60 in 4.20 seconds , 1/4 mile 12.80 @ 104 MPH



"Trying Times Are Not a Good Time To Quit Trying"
TSS is offline   Reply With Quote Quick reply to this message
Old 11-03-2012, 12:28 AM   #10 (permalink)
Junior Member
 
alton56's Avatar
 
Join Date: Nov 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Nice post. I like it. Thanks for sharing these information. Keep it up.
alton56 is offline   Reply With Quote Quick reply to this message
Old 11-03-2012, 05:08 AM   #11 (permalink)
TSS
Super Moderator

 
TSS's Avatar
 
Join Date: Mar 2010
Location: Michigan
Posts: 8,465
Thanks: 362
Thanked 737 Times in 402 Posts
?? Why are the hairs on my neck standing on end......

__________________
2009 Impala SS (sold 3/2012);
2010 Buick Enclave CXL;
2010 Lincoln MKS AWD Twin Turbo, Livernois Motor Sports tuned, K&N Typhoon CAI, 0-60 in 4.20 seconds , 1/4 mile 12.80 @ 104 MPH



"Trying Times Are Not a Good Time To Quit Trying"
TSS is offline   Reply With Quote Quick reply to this message
Old 11-03-2012, 05:41 AM   #12 (permalink)
Senior Member
 
auntjemima's Avatar
 
Join Date: May 2012
Location: Trenton, Ontario, Canada
Posts: 2,340
Thanks: 86
Thanked 311 Times in 239 Posts
Old age?

auntjemima is offline   Reply With Quote Quick reply to this message
Old 11-03-2012, 10:06 AM   #13 (permalink)
TSS
Super Moderator

 
TSS's Avatar
 
Join Date: Mar 2010
Location: Michigan
Posts: 8,465
Thanks: 362
Thanked 737 Times in 402 Posts
Quote:
Originally Posted by auntjemima View Post
Old age?
Possible......but my spam radar is up too......

__________________
2009 Impala SS (sold 3/2012);
2010 Buick Enclave CXL;
2010 Lincoln MKS AWD Twin Turbo, Livernois Motor Sports tuned, K&N Typhoon CAI, 0-60 in 4.20 seconds , 1/4 mile 12.80 @ 104 MPH



"Trying Times Are Not a Good Time To Quit Trying"
TSS is offline   Reply With Quote Quick reply to this message
Old 11-03-2012, 02:17 PM   #14 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,649
Thanks: 512
Thanked 1,180 Times in 780 Posts
Yeah, we get a number of those "nice post" guys. I have no idea what their end game is, but they offer us nothing.

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Old 11-06-2012, 07:05 AM   #15 (permalink)
Forum Foto Fanatic

 
tonyc712000's Avatar
 
Join Date: Apr 2011
Location: Connecticut
Posts: 14,093
Thanks: 3,596
Thanked 1,124 Times in 861 Posts
"sniff-sniff".... AH! Canned meat by-product!

__________________
Everyone has a photographic memory; some just don't have film.
************************************************** ******************************
1994 Caprice
265/200hp
Bought with 44k original miles
Sewer Pipe Intake, installed
Next upgrades to be:
Dual Exhaust
Shocks
More to come....

****************************************

2000 Impala 3.4 (Loaned out to family)
LS options
Mods: K&N Drop-in filter
Future add-ons: Chevy centers, trim rings,
Window tint
tonyc712000 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clicking noise while turning right BUCKEYE Automotive Discussion 6 07-13-2010 05:58 AM
impala clicking noise by alternator stanthemanimpala Chevy Impala 7th Gen Discussion 7 04-01-2010 09:53 AM
Clicking sound coming from distributor? badcompany87 1st - 5th Gen Engine Performance 5 08-09-2009 08:14 PM
My 03 Impala is in the shop for a clicking noise that seems to be coming K.M. Mechanical and Electrical Problems 0 09-03-2007 06:23 PM
I have an 03 Impala with 77 thousand miles. There is a clicking noise coming... K.M. Mechanical and Electrical Problems 1 09-03-2007 05:52 PM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.