96 imp emmision problems - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Vehicle-Specific B-Body Discussion > Chevy Impala Discussion

Chevy Impala Discussion Discuss all non-technical general Chevy Impala topics here.

Reply
 
LinkBack Thread Tools Display Modes
Old 07-01-2010, 04:27 AM   #1 (permalink)
Junior Member
 
SmallBlockCrusier's Avatar
 
Join Date: Apr 2010
Location: Philadelpia
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
96 imp emmision problems

Hello i have a 96 impala with emision problems i was just wondering if anybody ever had there EGR valve go bad on them if so what were the characteristics did it burn up the egr hose or anything. Im thinking its either my EGR valve or an o2 sensor. Any help well be well apriciated

SmallBlockCrusier is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some ?'s some problems CHILNLO Chevy Impala 6th Gen Discussion 0 02-09-2010 05:29 PM
just got a 9c and have a few problems capala22 Chevy Caprice 3 12-22-2009 04:48 PM
Problems!! DoctorCastle Chevy Impala 6th Gen Discussion 6 08-17-2009 10:27 AM
Heating Problems/Cd Problems ethelaugg Chevy Impala Discussion 0 01-14-2009 08:03 AM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.