is my waterpump bad? - Chevy Impala Forums
Chevy Impala Discussion Discuss all non-technical general Chevy Impala topics here.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-24-2010, 04:14 PM Thread Starter
Junior Member
newbie321's Avatar
Join Date: Jun 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
is my waterpump bad?


I have Chevy impala 2004 3.8 (base version)

I noticed that the engine is getting hotter than usual.
I examined the engine and I found no leaks anywhere. the radiator is full (and not clogged). Checked the fans: they work. My temperature gauge on the car never goes beyond 200 F (and this makes me wonder that I may be getting false readings)

Then I took off the thermostat, reconnected everything back and squeezed the upper radiator hose when engine was running. To my surprise the hose was really easy to squeeze and as I was squeezing it more and more I could not feel the water flow...It felt that I am squeezing a hose full of air.

The other observation, after driving the upper radiator hose would get extremely hot, but the radiator cap would just get warm. Also, I do not think the engine is clogged either.

does this mean that my waterpump is bad?

Also, what is that bleeder looking valve located on the very top of an aluminum flange that goes over the thermostat.
newbie321 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome