07 impala window defogger - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Performance and Technical > Chevy Impala 8th Gen Discussion

Chevy Impala 8th Gen Discussion W-Body 2006-2013. Discuss all Chevy Impala 8th Generation Performance and Technical Discussion here.

Reply
 
LinkBack Thread Tools Display Modes
Old 08-18-2009, 10:51 AM   #1 (permalink)
Junior Member
 
jhollen's Avatar
 
Join Date: Aug 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
07 impala window defogger

I have an 07 impala. The rear window defogger won't work. It happened about a year ago while under warrenty. The dealer mechanic said they replaced something under the dash that had collected moisture. He said it was a known problem. I'm out of warrenty so I'm doing it myself. I have checked the relay and the grid on the window and all related connections and all are ok. Can someone enlighten me if there is something under the dash like a connection or module I can check.

jhollen is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-18-2009, 01:01 PM   #2 (permalink)
Senior Member
 
blusail's Avatar
 
Join Date: Oct 2008
Location: WINSTON SALEM, NC
Posts: 416
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by jhollen View Post
I have an 07 impala. The rear window defogger won't work. It happened about a year ago while under warrenty. The dealer mechanic said they replaced something under the dash that had collected moisture. He said it was a known problem. I'm out of warrenty so I'm doing it myself. I have checked the relay and the grid on the window and all related connections and all are ok. Can someone enlighten me if there is something under the dash like a connection or module I can check.
Was it over a year ago? If they replaced a part and it was less than a year ago, then if the problem is the same part then can do a parts warranty on it and it shouldnt cost anything. If you have the invoice from when you had it done see if you can find a part number on there and I can tell you what the part that they replaced(if any).

blusail is offline   Reply With Quote Quick reply to this message
Old 08-18-2009, 01:58 PM   #3 (permalink)
Junior Member
 
jhollen's Avatar
 
Join Date: Aug 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
07 impala window defogger

Quote:
Originally Posted by blusail View Post
Was it over a year ago? If they replaced a part and it was less than a year ago, then if the problem is the same part then can do a parts warranty on it and it shouldnt cost anything. If you have the invoice from when you had it done see if you can find a part number on there and I can tell you what the part that they replaced(if any).
It has been over a year. I contacted the dealer. Being I was 2k miles over warranty they brushed me off. I even contacted GM and got the same result. When I said about a year, after checking it was several months past that.

jhollen is offline   Reply With Quote Quick reply to this message
Old 12-09-2009, 08:03 AM   #4 (permalink)
Junior Member
 
chaser1023's Avatar
 
Join Date: Oct 2009
Location: Mid Atlantic
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

can anyone else chime in on this....because my defogger isn't working either.
It just stopped....no idea why! I used to have a dealer less than four miles from my home, straight shot down the highway. They've closed down. next dealership is quite an inconvenient trip now. So I have really resorted to solving what I can when I can, but this defogger thing is just a mystery.

chaser1023 is offline   Reply With Quote Quick reply to this message
Old 12-09-2009, 10:26 AM   #5 (permalink)
Senior Member
 
POPIMPIN CUSTOMS I.N.C's Avatar
 
Join Date: Nov 2008
Location: COLORFUL COLORADO
Posts: 1,556
Thanks: 0
Thanked 0 Times in 0 Posts
damn pos new parts that they put on cars

__________________
4 B BODIES
2 SOLD CAPRICES
1995 9C1 UNDERCOVER CAR WHITE ON IMPALA SS'S muff delete/ hollowed cats / I.N.C. REP TILL I DIE
1991 CAPRICE CLASSIC 350 160,000 CUSTOM 20'S STOCK 2 TONE
1991 caprice 305 payed $600 sold 4 $1200
1965 OLDSMOBILE STARFIRE 425 BIG BLOCK 375+- HORSES SMASHES ON FORDS
POPIMPIN CUSTOMS I.N.C is offline   Reply With Quote Quick reply to this message
Old 12-30-2009, 12:46 AM   #6 (permalink)
Junior Member
 
LisaWilliams's Avatar
 
Join Date: Dec 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
If your vehicle rear window defogger does not appear to be doing the trick, it may have a faulty fuse or grid. Most of impala model come equipped with rear window defoggers as a standard feature and you can troubleshoot the defogger with a single kit available at most auto repair retailers.
LisaWilliams is offline   Reply With Quote Quick reply to this message
Old 01-22-2010, 01:44 AM   #7 (permalink)
Senior Member
 
mattkremer39's Avatar
 
Join Date: Jan 2010
Location: Columbus, Ohio
Posts: 113
Thanks: 0
Thanked 2 Times in 2 Posts
defog

Mine isn't working on my 06 SS. its so annoying!

mattkremer39 is offline   Reply With Quote Quick reply to this message
Old 01-22-2010, 07:42 AM   #8 (permalink)
Moderator
 
wanderson75's Avatar
 
Join Date: Apr 2009
Location: Southgate, MI
Posts: 1,660
Thanks: 0
Thanked 2 Times in 2 Posts
First, get a multimeter, you'll need this.

Start the car, and turn on your rear defroster, and read the voltage and make sure it's reading 12-14v. If not, then look at your fuse and circuit breaker. There's a 60A fuse in the bottom jbox under the hood. And a 30A circuit breaker behind the right side fuse box. If the fuse and circuit breaker are good, then it's the defroster relay.

If you ARE getting voltage:

Unplug the defroster leads on the back window and take a multimeter to your grid and read the resistance across it (the contacts on the window, not the leads that were plugged into it.). If it reads 0, it's open and the grid needs replaced. If it reads 1 or less (but not zero) it's shorted and needs replaced. If it's reading something else, then more than likely you have a wiring issue.

__________________


Quote:
in·sane   /ɪnˈseɪn/ Show Spelled[in-seyn] Show IPA
–adjective
1. not sane; not of sound mind; mentally deranged.
2. of, pertaining to, or characteristic of a person who is mentally deranged: insane actions; an insane asylum.
3. utterly senseless: an insane plan.
4. Swapping a 3.8V6 Supercharged into an 05 Base Impala.

Last edited by wanderson75; 01-22-2010 at 07:53 AM.. Reason: Rechecked my wiring diagrams.
wanderson75 is offline   Reply With Quote Quick reply to this message
Old 02-12-2010, 03:48 PM   #9 (permalink)
Junior Member
 
dit13841's Avatar
 
Join Date: Feb 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
wanderson75,

Would this be the same for an 06 impala? The reason I am asking is because by the owners manual I have a relay under the hood that I can hear work as I turn the defogger on and off so I am assume that is working ok. When I check voltage at rear window I get nothing again I am assume I have a blown fuse. So would my fuse be inside the right fuse box or would it be under the hood?

Thanks for your help

dit13841 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical connector 62 Impala power window javigolf Restoration Forum 5 09-22-2009 10:55 PM
77 impala 1/4 window trim Dime Restoration Forum 1 08-04-2009 03:25 PM
Window wont crank (62 impala)? vanessaskiss Chevy Impala Discussion 0 05-14-2008 12:25 AM
67 Chevy Impala Chrome Window Molding? l_alvarad0 Restoration Forum 1 11-20-2007 01:17 AM
My 2002 Impala driver window goes down but not up why? emmamom Mechanical and Electrical Problems 0 09-21-2007 10:44 AM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.