Squeak and clunk under hard breaking. - Chevy Impala Forums
Chevy Impala 7th Gen Discussion W-Body 2000-2005. Discuss all Chevy Impala 7th Generation Performance and Technical Discussion here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-29-2013, 04:18 PM Thread Starter
Senior Member
 
auntjemima's Avatar
 
Join Date: May 2012
Location: Trenton, Ontario, Canada
Posts: 3,227
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 197
Thanked 521 Times in 405 Posts
Squeak and clunk under hard breaking.

Ever since I threw on a front strut tower brace and the brackets from Don Rome my impala has been clunking and squeaking in the front end.

I checked tie rods, ball joints and sway bar links. All are at proper torque and under allowable play.

Sway bar bushings looks good.

My question is obviously what's causing it or suggestions but also I am curious if the transmission can cause this problem? I ask because as you break hard the wheels are connected through the CV axle to the internals... Can this cause any ill effects as hard acceleration can?




Sent from AutoGuide.com Free App
auntjemima is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 07-29-2013, 06:08 PM
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,655
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 517
Thanked 1,226 Times in 803 Posts
I'd imagine you probably have, but have you checked motor mounts, tightness of the STB mounts, and brake pads and calipers?

1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline  
post #3 of (permalink) Old 07-29-2013, 06:35 PM Thread Starter
Senior Member
 
auntjemima's Avatar
 
Join Date: May 2012
Location: Trenton, Ontario, Canada
Posts: 3,227
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 197
Thanked 521 Times in 405 Posts
i checked all of the above. I am going to remove my stb bar tomorrow and see what happens. I dont see it causing my issue but it started shortly after install.
auntjemima is offline  
post #4 of (permalink) Old 07-30-2013, 10:49 AM Thread Starter
Senior Member
 
auntjemima's Avatar
 
Join Date: May 2012
Location: Trenton, Ontario, Canada
Posts: 3,227
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 197
Thanked 521 Times in 405 Posts
After rechecking everything from all angles I have decided its likely my sway bar bushings. The mounting hemisphere is slightly twisted and the bushings are starting to come out of the metal sleeve.


Sent from AutoGuide.com Free App
auntjemima is offline  
post #5 of (permalink) Old 07-30-2013, 12:18 PM
Senior Member
 
GTXKen's Avatar
 
Join Date: Oct 2012
Location: Lowell, IN
Posts: 325
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 37 Times in 28 Posts
Makes sense, common cause for clunking front ends for many makes and models
GTXKen is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Squeak from front kevin 8th Gen Suspension 24 10-26-2012 12:36 PM
Annoying squeak Z71 Chevy Impala 8th Gen Discussion 12 09-08-2012 08:56 AM
Hell breaking loose Crime Scene Off-Topic Discussion 12 12-05-2011 10:47 AM
hopped curb, now wierd click (or thump) (or clunk) hard to describe tommymac23 8th Gen Suspension 9 02-20-2011 11:26 PM
I keep breaking the carrier bearing BigRedSleeper 1st - 5th Gen Drivetrain 12 10-20-2008 11:54 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome