2005 impala dash lites - Chevy Impala Forums
Chevy Impala 7th Gen Discussion W-Body 2000-2005. Discuss all Chevy Impala 7th Generation Performance and Technical Discussion here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-24-2013, 06:45 AM Thread Starter
Member
 
Carnegie's Avatar
 
Join Date: Sep 2009
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
2005 impala dash lites

Hey guys and gals. 2005, 3.4 with 171,000 kms. I have issues with my abs and traction control lites coming on. I know it is a sensor somewhere, it's a guessing game. Used to come on when the car got wet, then progressed to coming on as soon as I put the car in drive. Now, the lower left side red "brake " icon will lite up occasionally. Sometimes immediately, sometimes after 5 minutes, sometimes after 25 minutes or so. Brakes feel fine, but obviously there is an issue. Do not want to sink a lot of money age and mileage are a concern. But otherwise, it is a good car...any ideas?
Carnegie is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 03-24-2013, 07:53 AM
Back in Black
 
12ltz's Avatar
 
Join Date: Apr 2012
Location: Manassas or Suffolk,Va
Posts: 4,118
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 103
Thanked 230 Times in 161 Posts
Probably wire harness going to your wheel hub check for damage on wires and socket where they plug into the hubs. Could be wheel hub going bad or the sensor in hub going bad. Dealer or a good shop should be able to tell you which one or ones are bad.
check out search on forum lots of threads on this.
Good luck

_________________________

2012 Impala LTZ 72,000 miles
2002 Buick Regal LS 405,000 miles daughter traded for a ford
2000 Buick Regal LS 205,000 miles
1998 Olds Silhouette 3.4V6 177,000 miles


Too many freaks, not enough circuses.
12ltz is offline  
post #3 of (permalink) Old 03-24-2013, 11:52 AM Thread Starter
Member
 
Carnegie's Avatar
 
Join Date: Sep 2009
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for the quick reply. Just changed both my wheel bearing hubs in the front myself, and saw no frayed or cracked wires. Did the same cursory check in the rear, with nothing visible. I kinda figured I would have to go and have it scanned. Just hoping for an easy fix. (wouldn't that be nice once in a while? Ha ha )
Carnegie is offline  
post #4 of (permalink) Old 03-24-2013, 12:36 PM
Senior Member
 
jim1405's Avatar
 
Join Date: Sep 2012
Posts: 173
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 15 Times in 12 Posts
x2 on checking the harness. It can still be bad but not show any visible damage. Find an auto parts store that will scan abs codes for free to determine which wheel is throwing the error and then check that harness with an ohmmeter. Chevy issued a technical service bulletin about the harness being too short and/or rubbing against other parts. My right front harness was bad, got one from rockauto.com delivered for about 35 bucks and it was a simple fix.
jim1405 is offline  
post #5 of (permalink) Old 03-26-2013, 01:41 AM
Mr. Handy
 
g25racer's Avatar
 
Join Date: Apr 2012
Location: Michigan
Posts: 6,289
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 534
Thanked 844 Times in 673 Posts
^^ All great advice and very true. The abs harnesses are common to fail due to GM's mistake, esp the front one's. But, the abs sensor's/hub's are also a regular maint thing. After about 100-140k miles they tend to become worn out or dirty. All abs sensors are magnetic sensors so, if a small particle of iron/steel gets stuck on them, it tends to result in a replacement hub. Most of these abs sensor are non-serviceable which means, replacing the whole hub. Whenever you have an abs problem, inspect abs harnesses, clean terminals, and apply dielectric grease. Then, unhook battery for 10 min while key is ON. Then, start car and drive for a bit to see if light/s disappear. If not, take to a local shop or autoparts store that has an ABS CAPABLE OB2 SCANNER. Have a scan done to find the correct corner/area.

2001 Impala LS
TransGO Shift kit
Spectre Cone Filter
Thunderbolt Spun Cat
ZZP Alternator Power Cable
Wagner Thermoquiet Pads
KYB Strut Plus (Rr)
L67 Pass Eng Mount
Tinted tail lights
Painted Trim
Dipped Rims and emblems
Led plate, full interior, trunk, and console
Black interior accents (handles and switch panels)
JBL GTO 6.5" and 6x9"
Sony MEX-GS600BT
Hifonics Hifi 1500 (KnuKoncepts 4ga)
Rockford P3 @ 500rms
"Apply Dielectric Grease or I kick some arse"
g25racer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
weld drag lites! box_chevy_boy Wheels and Tires 2 01-04-2011 03:37 PM
Chevrolet : Impala Impala stationwagon,hide-a-way lites,protect-o-plate RSS Bot eBay Cars For Sale: Impala 0 07-15-2010 09:20 AM
I own a 2005 Chevrolet Impala trouble with dash panel gages, (gas,speedometer,temp.)? Javier G Mechanical and Electrical Problems 1 09-15-2008 06:58 PM
Can I put a in-dash navigation system in my 2005 Impala? lelani Chevy Impala Discussion 1 08-19-2008 01:43 PM
what would be better a 2005 chevy impala or a 2005 suzuki forenza? Slik 420 Chevy Impala Discussion 0 03-24-2008 12:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome