2005 3.4 impala code p0300 - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Performance and Technical > Chevy Impala 7th Gen Discussion

Chevy Impala 7th Gen Discussion W-Body 2000-2005. Discuss all Chevy Impala 7th Generation Performance and Technical Discussion here.

Reply
 
LinkBack Thread Tools Display Modes
Old 08-07-2011, 08:53 PM   #1 (permalink)
Senior Member
 
aztecs2006's Avatar
 
Join Date: Jul 2011
Location: Farmersville, CA
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
2005 3.4 impala code p0300

I went to turn on car this morning and it made a weird noise at first then stopped. Check engine light came on for first time ever. P0300 multiple cylinder misfire detected. Can anyone tell me how to find the problem. Is it bad to drive in the mean time. i posted a another thread a while mentioning my air pressure was 40 kpa. Someone told me that wasnt normal. I was reading about how a the intake might be leaking air. Can someone confirm.

aztecs2006 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-07-2011, 09:08 PM   #2 (permalink)
Senior Member
 
aztecs2006's Avatar
 
Join Date: Jul 2011
Location: Farmersville, CA
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
A few of you might know Ive also been having tranny problems. My tranny lags to shift into 2nd. I took my car for a test drive, it makes sort of a rattling noise when I accelerate.

aztecs2006 is offline   Reply With Quote Quick reply to this message
Old 08-07-2011, 09:12 PM   #3 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,649
Thanks: 512
Thanked 1,180 Times in 780 Posts
The rattling noise could be spark knock, I'm not sure, but that may be the cause of the code. I would be interested to see the live data readings on the spark advance.

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Old 08-07-2011, 09:20 PM   #4 (permalink)
Senior Member
 
aztecs2006's Avatar
 
Join Date: Jul 2011
Location: Farmersville, CA
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
How do I check those reading, I have obd-2 scan tool with a pcmscan program. I have never changed my spark plug wires, only spark plugs. Car has 125,000 miles.

aztecs2006 is offline   Reply With Quote Quick reply to this message
Old 08-07-2011, 09:23 PM   #5 (permalink)
Senior Member
 
aztecs2006's Avatar
 
Join Date: Jul 2011
Location: Farmersville, CA
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
Actually I just found it on my program spark advance(ignition timing advance #1 cylinder

aztecs2006 is offline   Reply With Quote Quick reply to this message
Old 08-07-2011, 09:27 PM   #6 (permalink)
Senior Member
 
aztecs2006's Avatar
 
Join Date: Jul 2011
Location: Farmersville, CA
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
Can I pm you kingnutin and send you a screen shot of the readings

aztecs2006 is offline   Reply With Quote Quick reply to this message
Old 08-07-2011, 09:37 PM   #7 (permalink)
Senior Member
 
aztecs2006's Avatar
 
Join Date: Jul 2011
Location: Farmersville, CA
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
Here are the readings
Attached Images
 

aztecs2006 is offline   Reply With Quote Quick reply to this message
Old 08-07-2011, 10:09 PM   #8 (permalink)
Senior Member
 
aztecs2006's Avatar
 
Join Date: Jul 2011
Location: Farmersville, CA
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
I reset the code, If it is a cylinder misfiring how long until the check engine comes back on.

aztecs2006 is offline   Reply With Quote Quick reply to this message
Old 08-07-2011, 11:10 PM   #9 (permalink)
Senior Member
 
aztecs2006's Avatar
 
Join Date: Jul 2011
Location: Farmersville, CA
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
Also if it was the spark knocking wouldnt it knock while idling, it only makes that rattling sound when im accelerating while driving.

aztecs2006 is offline   Reply With Quote Quick reply to this message
Old 08-08-2011, 10:54 AM   #10 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,649
Thanks: 512
Thanked 1,180 Times in 780 Posts
If you've never changed the wires, do that first, it needs to be done anyway. That data sheet doesn't show anything on the advance, I'm a bit confused by that. Just see how it does after the wires are done, we'll go from there.

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Old 08-08-2011, 05:58 PM   #11 (permalink)
Senior Member
 
aztecs2006's Avatar
 
Join Date: Jul 2011
Location: Farmersville, CA
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
Ima go ahead and replace both spark plugs and wires sometime this week. Any idea how to check if a have vacuum leak and if my coil packs are still good. Want to change it while im add it.

aztecs2006 is offline   Reply With Quote Quick reply to this message
Old 08-09-2011, 11:22 AM   #12 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,649
Thanks: 512
Thanked 1,180 Times in 780 Posts
The coil packs you can check the resistance of each one, for vacuum leaks you need a spray can of carb cleaner, brake cleaner, wd40, or something of the sort. With the engine running, spray it on all vacuum lines and fittings, one at a time, and see if the engine speed changes. If there is a change, you have a leak in that spot.

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Old 08-10-2011, 12:33 PM   #13 (permalink)
Senior Member
 
aztecs2006's Avatar
 
Join Date: Jul 2011
Location: Farmersville, CA
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
Got another problem, been having transmission problems for the past months. Before my car would lag before going into second. Now When I first accelerate my car lags and it wont go into first feels likes its pulling itself. Is that the transmission that finally shot itself.

aztecs2006 is offline   Reply With Quote Quick reply to this message
Old 08-11-2011, 10:49 AM   #14 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,649
Thanks: 512
Thanked 1,180 Times in 780 Posts
You probably just need to replace the solenoids.

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chevrolet : Impala IMPALA SS 1996 IMPALA SS- AUTHENTIC WX3 CODE IN A DGGM COLOR CODE RSS Bot eBay Cars For Sale: Impala 0 03-15-2011 08:30 PM
EST Code 42 monroe Automotive Discussion 5 12-13-2010 09:22 AM
2005 hw mm#5 8 1965 chevy impala c#2005-105 fte RSS Bot Impala Diecast Toys Cars on eBay 0 06-28-2010 10:50 AM
MAF Code dbede Automotive Discussion 2 03-14-2010 12:02 AM
what would be better a 2005 chevy impala or a 2005 suzuki forenza? Slik 420 Chevy Impala Discussion 0 03-24-2008 12:26 PM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.