Bad EGR valve? 2003 Impala 3.4L - Chevy Impala Forums
Chevy Impala 7th Gen Discussion W-Body 2000-2005. Discuss all Chevy Impala 7th Generation Performance and Technical Discussion here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-04-2011, 10:56 AM Thread Starter
Junior Member
 
JustinMP's Avatar
 
Join Date: Dec 2009
Location: Plattsburgh, NY
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Bad EGR valve? 2003 Impala 3.4L

Hey guys,

After taking care of all of the major problems with my Impala (LIMS for example), I've started to work on the smaller problems (rust, slight rough idle, etc).

I recently purchased the OBDPros USB scan tool. I decided on this one mainly because of the double buffering and firmware upgrade capability.. so I can keep it for a long time and still use it with newer vehicles.

My car has had this.. "whistling" sound when idling, it slightly changes with RPM, but I can't hear it when driving - it's probably drowned out. I also can't seem to hear it from the engine bay, which may also be because it'd being drowned out. I know there's a TSB on this sound, which describes how it is likely due to porosity in throttle body. I don't think porosity in the throttle body would cause what I found out below:

So... arrive the scan tool. At idle, my Short Term Fuel Trim ranges from 0-3, and my Long Term Fuel Trim stays around -14.1. Intake Manifold Absolute Pressure stays around 10.3 inHg, MAF stays around 0.54 lb/min, Ignition Timing Advance for cylinder #1 stays between 19-20. Idle RPM ranges from 650-740. When I say my car has a rough idle, I don't mean the engine sounds rough or the car shakes badly. But, the car shakes every 2 seconds. It's hard to describe but doesn't seem normal. Based on what I've been reading and the scan data I have.. it seems like I have a vacuum leak (MAP at 10.3 idle?), and the car is running rich ((Well, before being corrected by the FTs) LTFT at idle being -14) but I could be wrong.

Here is some data I graphed of a short drive:


I just have a feeling it could be the EGR valve based on what I've read.. but I was wondering if anyone here had any ideas. LIMS have already been changed and this whistling/"rough idle" was occurring before that.

Thanks and sorry if something like this has already been posted that I missed .
JustinMP is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 07-07-2011, 08:09 PM Thread Starter
Junior Member
 
JustinMP's Avatar
 
Join Date: Dec 2009
Location: Plattsburgh, NY
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I hate to bump.. but does anyone think I have a vacuum leak of some kind, and if so should I worry about it/any ideas where it might be?
JustinMP is offline  
post #3 of (permalink) Old 07-08-2011, 05:41 AM
Senior Member
 
AlfredoSmith's Avatar
 
Join Date: Jan 2010
Posts: 2,468
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 7 Times in 7 Posts
I was going to say it sounds like a possible vacuum leak... 9 times out of 10 i think the EGR would throw a code?

SPACE FOR RENT
AlfredoSmith is offline  
post #4 of (permalink) Old 07-08-2011, 12:31 PM
Moderator
 
04DetroitLS's Avatar
 
Join Date: May 2008
Posts: 3,391
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 10 Times in 6 Posts
map is low, should be around 16 iirc
MAF increase w/ throttle right?

any asshole can make a v8 fast
It takes a special breed oof stupid/crazy asshole to make a v6 fast



http:www.hellfiremotorsports.com/garage
04DetroitLS is offline  
post #5 of (permalink) Old 07-08-2011, 05:08 PM Thread Starter
Junior Member
 
JustinMP's Avatar
 
Join Date: Dec 2009
Location: Plattsburgh, NY
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
MAF does increase with throttle.
JustinMP is offline  
post #6 of (permalink) Old 07-12-2011, 09:55 PM Thread Starter
Junior Member
 
JustinMP's Avatar
 
Join Date: Dec 2009
Location: Plattsburgh, NY
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
So any ideas for what I should check? Maybe I could record the "whistling" sound I'm talking about..
JustinMP is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
EGR valve is bad salvador85 Chevy Impala 8th Gen Discussion 8 12-29-2015 11:34 AM
egr valve houimpala96 Chevy Impala 6th Gen Discussion 0 02-21-2011 07:06 AM
IAC Valve texaschevyryder Chevy Caprice 5 04-30-2010 05:29 PM
EGR valve griffenspade Chevy Caprice 3 02-12-2010 07:17 PM
Which of these cars would be better 2003 nissan altima, 2003 toyota camry, 2003 camille b Chevy Impala Discussion 8 05-14-2008 10:30 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome