mileage on cluster - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Performance and Technical > Chevy Impala 7th Gen Discussion

Chevy Impala 7th Gen Discussion W-Body 2000-2005. Discuss all Chevy Impala 7th Generation Performance and Technical Discussion here.

Reply
 
LinkBack Thread Tools Display Modes
Old 10-19-2010, 09:25 AM   #1 (permalink)
Senior Member
 
brigoyanks's Avatar
 
Join Date: Dec 2009
Location: NJ
Posts: 392
Thanks: 0
Thanked 4 Times in 2 Posts
mileage on cluster

so i got a new cluster because my old one broke and i wanted the upgraded one with all the extra gauges and now my mileage is off..by like 120,000 miles....how do i fix this and make it say my correct mileage? any suggestions

2004 impala 3.4l with a Monte Carlo SS cluster swap

brigoyanks is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-20-2010, 02:09 PM   #2 (permalink)
Senior Member
 
brigoyanks's Avatar
 
Join Date: Dec 2009
Location: NJ
Posts: 392
Thanks: 0
Thanked 4 Times in 2 Posts
does anyone think i can get it done at the dealership?

brigoyanks is offline   Reply With Quote Quick reply to this message
Old 10-20-2010, 03:22 PM   #3 (permalink)
Carpe Diem


 
donmateo's Avatar
 
Join Date: Aug 2009
Location: Racine, WI
Posts: 19,739
Thanks: 2,253
Thanked 1,855 Times in 1,259 Posts
Send a message via MSN to donmateo Send a message via Skype™ to donmateo
Maybe, give em a call and check it out and see. The worst they'll say is no.

__________________
www.basilonestopshop.com
Basil One-Stop Shop BBM Channel: C00120B93
Basil One-Stop Shop BBM Customer Service Chat Available
donmateo is online now   Reply With Quote Quick reply to this message
Old 10-20-2010, 07:52 PM   #4 (permalink)
Senior Member
 
brigoyanks's Avatar
 
Join Date: Dec 2009
Location: NJ
Posts: 392
Thanks: 0
Thanked 4 Times in 2 Posts
figured it out.. found a guy who does them..he also does the LED backlighting too...turns out he lives in the town next to me....lol small world BBEngineering

brigoyanks is offline   Reply With Quote Quick reply to this message
Old 10-20-2010, 07:59 PM   #5 (permalink)
Carpe Diem


 
donmateo's Avatar
 
Join Date: Aug 2009
Location: Racine, WI
Posts: 19,739
Thanks: 2,253
Thanked 1,855 Times in 1,259 Posts
Send a message via MSN to donmateo Send a message via Skype™ to donmateo
Yeah, he's well known, I don't recommend him personally, but I've got beef. Heard he does good work, though.

__________________
www.basilonestopshop.com
Basil One-Stop Shop BBM Channel: C00120B93
Basil One-Stop Shop BBM Customer Service Chat Available
donmateo is online now   Reply With Quote Quick reply to this message
Old 10-25-2010, 04:52 PM   #6 (permalink)
Member
 
Scoobywic's Avatar
 
Join Date: Oct 2010
Location: Wichita Kansas
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Smile Question about SS speedometers

I literally joined this forum so that I could ask you this because you are the only person (apparently, I did some searching through this site but just couldn't find just what I was looking for) that has posted much about the instrument clusters on the 7th gen Impalas. I was wondering if the instrument clusters from the SS are "plug and play" with the base model Impala... I have a base model (for now) and I plan to do a lot of upgrading on it and one of the first things I would like to do is to get a tachometer but I want it to look as close to stock as possible, I'm not a big fan of the 7-inch tach ghetto mounted on my dash that obviously didn't come with the car so I decided on the SS cluster. I just want to verify that it will be a somewhat easy install. (plug and play would be AWESOME)

P.S. I plan on making a thread here for my car, I enjoy sharing my work with others even though I'm definitely a newbie.

Thank you,
Scoobywic

Scoobywic is offline   Reply With Quote Quick reply to this message
Old 10-25-2010, 05:26 PM   #7 (permalink)
Carpe Diem


 
donmateo's Avatar
 
Join Date: Aug 2009
Location: Racine, WI
Posts: 19,739
Thanks: 2,253
Thanked 1,855 Times in 1,259 Posts
Send a message via MSN to donmateo Send a message via Skype™ to donmateo
^^Thanks for joining! Please introduce yourself in the proper forum sub-section.

To answer: Yes, it IS plug and play, BUT your oil gauge will NOT work. You could go for an A-Pillar gauge system, as well. Can't wait for pics!

__________________
www.basilonestopshop.com
Basil One-Stop Shop BBM Channel: C00120B93
Basil One-Stop Shop BBM Customer Service Chat Available
donmateo is online now   Reply With Quote Quick reply to this message
Old 10-25-2010, 05:57 PM   #8 (permalink)
Member
 
Scoobywic's Avatar
 
Join Date: Oct 2010
Location: Wichita Kansas
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Smile Thanks!

Okay cool! That is the only gauge that won't work correct? The tach, speed, gas, and temp will? I will upload as soon as I get home haha, working late tonight.

Scoobywic is offline   Reply With Quote Quick reply to this message
Old 10-25-2010, 07:40 PM   #9 (permalink)
Carpe Diem


 
donmateo's Avatar
 
Join Date: Aug 2009
Location: Racine, WI
Posts: 19,739
Thanks: 2,253
Thanked 1,855 Times in 1,259 Posts
Send a message via MSN to donmateo Send a message via Skype™ to donmateo
IIRC, only the oil doesn't work. If you can, find a LS Sport gauge, then I think all gauges will work via plug n play.

And sounds good! Have with the fun late night! ;)

__________________
www.basilonestopshop.com
Basil One-Stop Shop BBM Channel: C00120B93
Basil One-Stop Shop BBM Customer Service Chat Available
donmateo is online now   Reply With Quote Quick reply to this message
Old 10-25-2010, 09:20 PM   #10 (permalink)
Member
 
Scoobywic's Avatar
 
Join Date: Oct 2010
Location: Wichita Kansas
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Haha, I got the pictures and a whole thread up already. They are in this section. Does the LS "sport" gauge come in all LS's? Or only certain ones? Also does this work for 2000 - 05 or is it only for 2002 since thats the year mine is. I've read that theres a difference in pre-2003 Impalas even though they are still 7th gen, any idea about that?

Scoobywic is offline   Reply With Quote Quick reply to this message
Old 10-26-2010, 05:13 AM   #11 (permalink)
Moderator
 
wanderson75's Avatar
 
Join Date: Apr 2009
Location: Southgate, MI
Posts: 1,660
Thanks: 0
Thanked 2 Times in 2 Posts
I've you have a 3.4L engine, the oil press on the LS and SS clusters will not work. If you have a 3.8L engine (which came in some base models) it will work fine.

And BBEngineer does awesome work and is a great guy. Donmateo just got on his bad side. :-P

__________________


Quote:
in·sane   /ɪnˈseɪn/ Show Spelled[in-seyn] Show IPA
–adjective
1. not sane; not of sound mind; mentally deranged.
2. of, pertaining to, or characteristic of a person who is mentally deranged: insane actions; an insane asylum.
3. utterly senseless: an insane plan.
4. Swapping a 3.8V6 Supercharged into an 05 Base Impala.
wanderson75 is offline   Reply With Quote Quick reply to this message
Old 10-26-2010, 02:43 PM   #12 (permalink)
Carpe Diem


 
donmateo's Avatar
 
Join Date: Aug 2009
Location: Racine, WI
Posts: 19,739
Thanks: 2,253
Thanked 1,855 Times in 1,259 Posts
Send a message via MSN to donmateo Send a message via Skype™ to donmateo
^Tool...... :P

FYI, I didn't even do anything, he just wanted to ban me. Ask, TSS, (not to drag him into this) but he knows. It was all about a stupid joke.

And, PS, I've you have? Come on, Wanderson, you're better than that!

The gauge came in LS Sports and I think only 2000s were the issue.

__________________
www.basilonestopshop.com
Basil One-Stop Shop BBM Channel: C00120B93
Basil One-Stop Shop BBM Customer Service Chat Available
donmateo is online now   Reply With Quote Quick reply to this message
Old 10-26-2010, 04:26 PM   #13 (permalink)
Moderator
 
wanderson75's Avatar
 
Join Date: Apr 2009
Location: Southgate, MI
Posts: 1,660
Thanks: 0
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by donmateo View Post
And, PS, I've you have? Come on, Wanderson, you're better than that!

The gauge came in LS Sports and I think only 2000s were the issue.
Rewind that sentence...what?

And what issue with the 2000s?

__________________


Quote:
in·sane   /ɪnˈseɪn/ Show Spelled[in-seyn] Show IPA
–adjective
1. not sane; not of sound mind; mentally deranged.
2. of, pertaining to, or characteristic of a person who is mentally deranged: insane actions; an insane asylum.
3. utterly senseless: an insane plan.
4. Swapping a 3.8V6 Supercharged into an 05 Base Impala.
wanderson75 is offline   Reply With Quote Quick reply to this message
Old 10-26-2010, 05:01 PM   #14 (permalink)
Carpe Diem


 
donmateo's Avatar
 
Join Date: Aug 2009
Location: Racine, WI
Posts: 19,739
Thanks: 2,253
Thanked 1,855 Times in 1,259 Posts
Send a message via MSN to donmateo Send a message via Skype™ to donmateo
Quote:
Originally Posted by wanderson75 View Post
I've you have a 3.4L engine, the oil press on the LS and SS clusters will not work. If you have a 3.8L engine (which came in some base models) it will work fine.

And BBEngineer does awesome work and is a great guy. Donmateo just got on his bad side. :-P
The plug issue or whatever it was. Something about how only 2000 gauges worked with 2000s.

__________________
www.basilonestopshop.com
Basil One-Stop Shop BBM Channel: C00120B93
Basil One-Stop Shop BBM Customer Service Chat Available
donmateo is online now   Reply With Quote Quick reply to this message
Old 10-27-2010, 01:13 AM   #15 (permalink)
Senior Member
 
brigoyanks's Avatar
 
Join Date: Dec 2009
Location: NJ
Posts: 392
Thanks: 0
Thanked 4 Times in 2 Posts
i just got a 2000 gauge for my 2004 all the gauges work except the oil cause i have a 3.4l...BBEngineer is programing right now for me

__________________
2007 Impala 3.5l

2004 Impala 3400SFI LA1 (SOLD!)

Performance Mods: Custom k&n FWI, Thrush Weld Dual Mufflers, Dual 3" T304 SS Tips, 180° t-stat, ZZP Downpipe, High-Flow Magnaflow Cat, High Flow Fuel Filter, Adjustable Fuel Pressure Regulator, ZZP Poly Dogbone Mounts, Overkill PCM, TCE 65mm TB, WOT-Tech Upper/Lower Intake Manifold, EGR Delete, Poly Trans Mount

PLEASE VOTE FOR ITOM
http://www.impalaforums.com/iotm-sub...ns-and-voting/
brigoyanks is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Z28 Cluster Conversion mmd8x28 Chevy Caprice 8 10-30-2010 02:58 PM
Cluster gone BAD iceship Chevy Impala 6th Gen Discussion 4 09-08-2010 11:34 PM
Speed cluster Smooth Operator Chevy Impala 6th Gen Discussion 7 05-02-2010 02:30 PM
gauge cluster ?s Natedogg713 Chevy Impala 7th Gen Discussion 32 02-07-2010 02:13 PM
Cluster bulbs scirks Chevy Impala 7th Gen Discussion 2 01-10-2009 02:39 PM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.