Gas gauge does not work - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Performance and Technical > Chevy Impala 7th Gen Discussion

Chevy Impala 7th Gen Discussion W-Body 2000-2005. Discuss all Chevy Impala 7th Generation Performance and Technical Discussion here.

Reply
 
LinkBack Thread Tools Display Modes
Old 12-21-2008, 12:48 PM   #1 (permalink)
Member
 
mmanter's Avatar
 
Join Date: Dec 2008
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Gas gauge does not work

I have read about problems with the gas gauges on the generation Impala my dad has, and his is not immune.

When we got the car it would work intermittently, but now the gas gauge needle is always pointing around the 6:00 position. Is this probably a problem with the cluster or something at the fuel pump itself?

Any info that can be sent my way is appreciated so I can fix the problem.

__________________
Matt Manter
2004 Impala
mmanter is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-25-2008, 10:35 AM   #2 (permalink)
Member
 
Fearless 2005's Avatar
 
Join Date: Jun 2008
Location: CHICAGO
Posts: 88
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by mmanter View Post
I have read about problems with the gas gauges on the generation Impala my dad has, and his is not immune.

When we got the car it would work intermittently, but now the gas gauge needle is always pointing around the 6:00 position. Is this probably a problem with the cluster or something at the fuel pump itself?

Any info that can be sent my way is appreciated so I can fix the problem.
Are you getting any CEL's? If your not then I am guessing your gauge is bad. Or even possibly a ground somewhere.

My coolant gauge is not working and I have no CEL's. And your right, these cars are infamous for those gauges.

Fearless 2005 is offline   Reply With Quote Quick reply to this message
Old 12-25-2008, 10:39 AM   #3 (permalink)
Member
 
Fearless 2005's Avatar
 
Join Date: Jun 2008
Location: CHICAGO
Posts: 88
Thanks: 0
Thanked 0 Times in 0 Posts
It may also be a sender in the gas tank......

I highly doubt your pump is bad. If it was, then it wouldn't be preasurizing fuel through to the injectors.

Fearless 2005 is offline   Reply With Quote Quick reply to this message
Old 12-26-2008, 12:34 PM   #4 (permalink)
Senior Member
 
blusail's Avatar
 
Join Date: Oct 2008
Location: WINSTON SALEM, NC
Posts: 416
Thanks: 0
Thanked 0 Times in 0 Posts
A fix for the problem could also be a level sensor in the tank is getting hung up and not reading correctly

blusail is offline   Reply With Quote Quick reply to this message
Old 12-28-2008, 07:20 PM   #5 (permalink)
Member
 
mmanter's Avatar
 
Join Date: Dec 2008
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for the replies guys.

There was an Impala at the junkyard so I went ahead & grabbed the fuel level sensor off the pump. The cluster is the deluxe with the tach or I would ahve grabbed that as well.

Will the speedo swap out & retain the mileage if I grab the cluster?

__________________
Matt Manter
2004 Impala
mmanter is offline   Reply With Quote Quick reply to this message
Old 12-28-2008, 07:22 PM   #6 (permalink)
Member
 
mmanter's Avatar
 
Join Date: Dec 2008
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
forgot to mention I did test the replacement sensor & it doesn't seem to have any dead spots & the resistance varies depending on the position of the float arm. I'll update after I swap it out on wednesday.

__________________
Matt Manter
2004 Impala
mmanter is offline   Reply With Quote Quick reply to this message
Old 12-28-2008, 07:23 PM   #7 (permalink)
Member
 
mmanter's Avatar
 
Join Date: Dec 2008
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Fearless 2005 View Post
Are you getting any CEL's? If your not then I am guessing your gauge is bad. Or even possibly a ground somewhere.

My coolant gauge is not working and I have no CEL's. And your right, these cars are infamous for those gauges.
Now that I think of it, he has an intermittent check engine light. Currently it is out but it has been on before & when I was gonna check the code it went out.

__________________
Matt Manter
2004 Impala
mmanter is offline   Reply With Quote Quick reply to this message
Old 02-02-2009, 11:44 AM   #8 (permalink)
Junior Member
 
dorman68's Avatar
 
Join Date: Feb 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
The fuel level sensor in the tank is a common failure part.

dorman68 is offline   Reply With Quote Quick reply to this message
Old 02-03-2009, 12:48 AM   #9 (permalink)
GTR
Member
 
GTR's Avatar
 
Join Date: Sep 2008
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Your needle is suffering from a condition called "limp dick syndrome".
GTR is offline   Reply With Quote Quick reply to this message
Old 02-03-2009, 03:21 AM   #10 (permalink)
Senior Member
 
capricewiz's Avatar
 
Join Date: Apr 2008
Location: Doylestown, PA
Posts: 556
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via AIM to capricewiz
You can buy just a fuel level sensor from the dealer for like $30

capricewiz is offline   Reply With Quote Quick reply to this message
Old 02-03-2009, 03:55 AM   #11 (permalink)
Junior Member
 
dorman68's Avatar
 
Join Date: Feb 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by capricewiz View Post
You can buy just a fuel level sensor from the dealer for like $30
capricewiz,

Wow thats a great price. My cousing has an 04 Impala and his gauge was not working and the local dealer quoted me $180.00 just for the level sensor by itself. Do you know where I can get one for $30 or do you have an part number I can order from the dealer?

dorman68 is offline   Reply With Quote Quick reply to this message
Old 02-03-2009, 01:51 PM   #12 (permalink)
Senior Member
 
blusail's Avatar
 
Join Date: Oct 2008
Location: WINSTON SALEM, NC
Posts: 416
Thanks: 0
Thanked 0 Times in 0 Posts
180 Is The List Price On That Level Sensor And The Part Number Is 89060197

blusail is offline   Reply With Quote Quick reply to this message
Old 02-04-2009, 04:24 AM   #13 (permalink)
Junior Member
 
dorman68's Avatar
 
Join Date: Feb 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by blusail View Post
180 Is The List Price On That Level Sensor And The Part Number Is 89060197
Thanks blusail

dorman68 is offline   Reply With Quote Quick reply to this message
Old 02-04-2009, 10:48 AM   #14 (permalink)
Junior Member
 
bad03xtreme's Avatar
 
Join Date: Feb 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
I am looking at an 04' SS and the photo online has the same issue you are describing here is a photo they have posted online. Do you think it is the level sensor issue and I should try and get them to knock the price down a bit.


bad03xtreme is offline   Reply With Quote Quick reply to this message
Old 02-04-2009, 01:54 PM   #15 (permalink)
Senior Member
 
blusail's Avatar
 
Join Date: Oct 2008
Location: WINSTON SALEM, NC
Posts: 416
Thanks: 0
Thanked 0 Times in 0 Posts
I would say that looks like a cluster problem and not the level sensor

blusail is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
My 2004 Chevy Impala is having gauge problems. The gas gauge is off, the... astrokien Mechanical and Electrical Problems 7 09-30-2008 06:53 AM
My 2008 Chevy Impala LS,the gas gauge wont work? Henry M Chevy Impala Discussion 3 09-15-2008 08:35 AM
fuel gauge doesn't work on impala? jazam Chevy Impala Discussion 1 08-12-2008 08:27 PM
gauge wiring for the 66 wjforbes Automotive Discussion 0 04-11-2008 04:50 PM
gmc canyon all three lights work on tailight assembly but the tail light dont work.? denny b Automotive Discussion 1 09-07-2007 04:56 AM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.