Held hostage by my security system! - Chevy Impala Forums
Chevy Impala 7th Gen Discussion W-Body 2000-2005. Discuss all Chevy Impala 7th Generation Performance and Technical Discussion here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-31-2017, 08:32 PM Thread Starter
Junior Member
 
Fangly's Avatar
 
Join Date: May 2017
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Held hostage by my security system!

Hi! This is my first post, so bear with me! I own a 2001 Impala base 3.4L that I purchased to fix up for resale. Unfortunately, over the winter I let the battery run down, and when I tried to charge it up, it wouldn't hold a charge, so I replaced it. Now I'm hostage to the security system. I insert the key, the cluster lights up, but no crank. The red light on the radio is flashing, and I get assorted messages on the display. I've looked at various information online and this is what I have tried: pulling the BCM fuse repeatedly; no luck. Leaving the key in the On position for more than 10 minutes (the red light on the radio never goes steady); no luck. I cannot get into the menu on the radio; it shows the time and then nothing. The car is in a dry and tight storage unit, so no moisture/weather damage. I have trouble believing that the BCM is bad; everything was working just fine before I let the battery run down. Never a problem in starting the car previously, so I'm at my wit's end. I really don't want to have the car towed to the dealer for them to charge me mucho bucks for a (hopefully!) simple fix. I know other models have had this same problem, so that is why I posted in this forum versus the Impala one. Does anyone have a solution before I wash my hands of this crate, and haul it off to the junkyard? Thanks in advance!!
Fangly is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 06-01-2017, 05:12 AM
Senior Member
 
plano-doug's Avatar
 
Join Date: Aug 2009
Location: Plano, Texas
Posts: 1,299
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)
Thanks: 94
Thanked 222 Times in 205 Posts
Quote:
Originally Posted by Fangly View Post
Hi! This is my first post, so bear with me! I own a 2001 Impala base 3.4L that I purchased to fix up for resale. Unfortunately, over the winter I let the battery run down, and when I tried to charge it up, it wouldn't hold a charge, so I replaced it. Now I'm hostage to the security system. I insert the key, the cluster lights up, but no crank. The red light on the radio is flashing, and I get assorted messages on the display. I've looked at various information online and this is what I have tried: pulling the BCM fuse repeatedly; no luck. Leaving the key in the On position for more than 10 minutes (the red light on the radio never goes steady); no luck. I cannot get into the menu on the radio; it shows the time and then nothing. The car is in a dry and tight storage unit, so no moisture/weather damage. I have trouble believing that the BCM is bad; everything was working just fine before I let the battery run down. Never a problem in starting the car previously, so I'm at my wit's end. I really don't want to have the car towed to the dealer for them to charge me mucho bucks for a (hopefully!) simple fix. I know other models have had this same problem, so that is why I posted in this forum versus the Impala one. Does anyone have a solution before I wash my hands of this crate, and haul it off to the junkyard? Thanks in advance!!
Do you see the SECURITY light flashing in the instrument cluster?

Doug

.
plano-doug is offline  
post #3 of (permalink) Old 06-01-2017, 08:44 PM Thread Starter
Junior Member
 
Fangly's Avatar
 
Join Date: May 2017
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
The word SECURITY shows on the message center, then rotates with the battery icon, etc. The red light that is flashing is on the radio. Fangly
Fangly is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Security system jso2378 Chevy Impala 8th Gen Discussion 15 01-26-2017 07:42 PM
Security System Issues MattieP Mechanical and Electrical Problems 2 03-24-2012 06:35 PM
How do you reset security system light? Hersbird Chevy Impala 8th Gen Discussion 5 05-03-2011 05:28 PM
Can anyone help me with the security system on a 2003 Chevy Impala? I have from time manicbhpp Audio, Video, and Electronics 1 09-17-2007 06:01 PM
Security system problems in 2000 Pon. Grand Prix GTP? Dragonflyshan Automotive Discussion 0 09-09-2007 03:59 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome