96 Impala SS odometer cluster problem!!! - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Performance and Technical > Chevy Impala 6th Gen Discussion

Chevy Impala 6th Gen Discussion B-Body 1994, 1995, 1996. Discuss all Chevy Impala 6th Generation Performance and Technical Discussion here.

Reply
 
LinkBack Thread Tools Display Modes
Old 09-30-2009, 08:45 PM   #1 (permalink)
Junior Member
 
mraztek's Avatar
 
Join Date: Aug 2009
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
96 Impala SS odometer cluster problem!!!

Hello,

well i have a 96 Impala SS and everything works fine last month the odometer cluster was 120XXX miles but sense last week the milage its not showing up! I hear from friends its common problem on this cars, but anyways does anyone know how to fix it? All the cluster gages works fine just the milage doesnt show up nathing!!!!

Any idea can help!
Thank you!

mraztek is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-30-2009, 11:59 PM   #2 (permalink)
Member
 
Keylo94SS's Avatar
 
Join Date: Feb 2009
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Hit up Angel from George Bates Automotive he can probably help you out. If not im sure he will know someone who can.

Keylo94SS is offline   Reply With Quote Quick reply to this message
Old 10-18-2009, 08:50 PM   #3 (permalink)
Junior Member
 
SSanity's Avatar
 
Join Date: Oct 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
'96 Impala Odometer Repair Kit

Years ago I had a similar problem. Your odometer is no-longer illuminated most likely because of failed solder joints. Over time, repeated thermal stress from the heat given off by it's resisters causes the failure. There was a write up with pictures on the Region of Doom websight before a server crash. I purchased a kit with directions from Jim Bordelon out of Louisiana. It came with a resister & heatsink and took me 3-4 hours to complete with some soldering required.

SSanity is offline   Reply With Quote Quick reply to this message
Old 10-19-2009, 10:27 AM   #4 (permalink)
Senior Member
 
fatvet's Avatar
 
Join Date: Mar 2008
Location: suffield, CT.
Posts: 118
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via AIM to fatvet
Thumbs up fix it

go buy this

http://impalasuperstore.com/supersto...exd.asp?id=694

it is a DIY job......


-ALF out....

__________________
96' WX3 DGGM ISSCA # 01978 #7635 SS on the line http://www.cardomain.com/ride/2386222/1
Bilstein 0929/1104 odom fade mod, FB&HP delete,Pypes-X,Spintech Super Pro Streets, lower bushing mod,Stealth Brake Bolt,Bonnies,SS-Studio TB boot,9C1 air dams
69' vert stingray
00' 1200C sportster with V&H Straight shots !!

Last edited by fatvet; 01-02-2010 at 05:44 AM.. Reason: fixed the URL
fatvet is offline   Reply With Quote Quick reply to this message
Old 11-12-2009, 04:04 PM   #5 (permalink)
Junior Member
 
nineSSexy209's Avatar
 
Join Date: Nov 2009
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
have the same problem

nineSSexy209 is offline   Reply With Quote Quick reply to this message
Old 01-01-2010, 12:27 PM   #6 (permalink)
Junior Member
 
gwen's95's Avatar
 
Join Date: Jan 2010
Location: Jacksonville, NC
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Hey, Alf, this link is no good.

gwen's95 is offline   Reply With Quote Quick reply to this message
Old 01-01-2010, 02:38 PM   #7 (permalink)
Senior Member
 
waynes91's Avatar
 
Join Date: Nov 2008
Location: gales ferry ct.
Posts: 609
Thanks: 0
Thanked 10 Times in 9 Posts
try http://www.impalasuperstore.com/nais...TOPIC_ID=47406

waynes91 is offline   Reply With Quote Quick reply to this message
Old 01-02-2010, 05:45 AM   #8 (permalink)
Senior Member
 
fatvet's Avatar
 
Join Date: Mar 2008
Location: suffield, CT.
Posts: 118
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via AIM to fatvet
the superstore website got updated so i fixed the link.
the fix is for 96' ss only though...
-ALF out...

__________________
96' WX3 DGGM ISSCA # 01978 #7635 SS on the line http://www.cardomain.com/ride/2386222/1
Bilstein 0929/1104 odom fade mod, FB&HP delete,Pypes-X,Spintech Super Pro Streets, lower bushing mod,Stealth Brake Bolt,Bonnies,SS-Studio TB boot,9C1 air dams
69' vert stingray
00' 1200C sportster with V&H Straight shots !!
fatvet is offline   Reply With Quote Quick reply to this message
Old 01-03-2010, 11:33 AM   #9 (permalink)
Member
 
bville_boy's Avatar
 
Join Date: Sep 2009
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
I wonder if that is the problem I'm having :confused:...odometer changes numbers often, then goes back to the normal. All my dash gauges will light up...WITH MY KEY OUT THE IGNITION...or I was also going to ask if maybe it was a wiring defect and if my car needed rewiring or have my wires looked at.

bville_boy is offline   Reply With Quote Quick reply to this message
Old 01-03-2010, 07:09 PM   #10 (permalink)
Junior Member
 
94bubble's Avatar
 
Join Date: Dec 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
ya i had same prob with my 94 caprice the mileage would go all screwy then back to normal i unplugged my battery for a couple min and i hasnt done it since...

94bubble is offline   Reply With Quote Quick reply to this message
Old 01-04-2010, 04:35 PM   #11 (permalink)
Member
 
bville_boy's Avatar
 
Join Date: Sep 2009
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by 94bubble View Post
ya i had same prob with my 94 caprice the mileage would go all screwy then back to normal i unplugged my battery for a couple min and i hasnt done it since...
No, it's worst than you think ...i has me going gray trying to figure this out...i went by a few shops today and spoke with one guy who said more than likely it's a shortage in my wiring harness or something...now i have to figure out how much is a wiring harness for a '96, i don't know any websites...

bville_boy is offline   Reply With Quote Quick reply to this message
Old 03-14-2011, 08:48 AM   #12 (permalink)
Junior Member
 
Dril-Dr's Avatar
 
Join Date: Mar 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
The odometer on my 96 does the same thing but in the winter when I have the heat on the odometer randomly lights up. Must be something with heat expansion or something???

Dril-Dr is offline   Reply With Quote Quick reply to this message
Old 03-14-2011, 01:45 PM   #13 (permalink)
Junior Member
 
*ThatBoiFasst*'s Avatar
 
Join Date: Feb 2011
Location: Portland Oregon
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
My Numbers on mine would get all wierd whenever i would have the heat coming out of my vents for a while. the guy i got the car from said that sometimes it gets really hot back there so you gotta put the knob to Defrost, or just blast the cold air to cool it down a little. the first month i had the car it did it a lot, but now i havnt seen it act up in about a month and a half....

__________________
*ThatBoiFaSSt*
*ThatBoiFasst* is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Odometer problems impalaryder Mechanical and Electrical Problems 14 05-05-2011 12:58 PM
Odometer changes mileage for no reason I presume?! bville_boy Automotive Discussion 8 09-28-2009 02:10 PM
Intermitent odometer ahiggins Chevy Impala 6th Gen Discussion 1 09-11-2009 01:39 PM
digital odometer Targe72 Chevy Impala Discussion 2 12-11-2008 12:16 PM
1996 impala odometer not working 206SS Chevy Impala 6th Gen Discussion 4 09-16-2008 07:05 AM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.