1994 lt1 problems.. - Chevy Impala Forums
Chevy Caprice General and Technical discussion for the Chevy Caprice (1965-1996), which shares the B-Body platform with the Chevy Impala.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 04-01-2012, 04:59 PM Thread Starter
Member
 
ChevyCaprice1994's Avatar
 
Join Date: Apr 2011
Location: Maryland
Posts: 58
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ChevyCaprice1994
1994 lt1 problems..

I have a 1994 caprice with the lt1 motor in it and as i was driving today i discovered when i came to a hill it lost all of its power and eventually came to a complete stop, While this is all happening theres like a bubbling sound coming from the bottem of the block it sounds. I added transmission fluid because it was low thinking it would solve the issue but it's still doing the same thing. The car isn't running hot but my oil pressure guage is constantly on high, i'v never noticed this before and thought it might just be a short in my dash because the speedometer stopped working as well. Does anyone know what i could do to try to solve this issue, oh yeah and the car smells like it's burning oil. Maybe the oil pressure regulator is bad? But i'm not sure what that would cause if anyone has any suggestions feel free to help.
ChevyCaprice1994 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 04-24-2012, 10:15 PM
Junior Member
 
cado0187's Avatar
 
Join Date: Jan 2011
Location: Mt pleasant TX
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
i have a 96 lt1 and its doing the same thing. if you find out what the cause of these problems please post the solution...
cado0187 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C problems help!! Cok3_09SS Chevy Impala 8th Gen Discussion 5 09-06-2011 02:52 PM
IAC Problems? kingnutin Chevy Impala 7th Gen Discussion 21 06-23-2011 04:58 PM
Any known problems with the 3.5? Cool Hand Hodge Chevy Impala 8th Gen Discussion 6 01-20-2011 07:13 PM
Heating Problems/Cd Problems ethelaugg Chevy Impala Discussion 0 01-14-2009 08:03 AM
how do i tell a 1994 impala SS from a 1994 caprice? aroot Chevy Impala Discussion 2 02-04-2008 06:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome