My 2007 Impala - Chevy Impala Forums
Audio, Video, and Electronics All audio, video, alarms, and all other electronics.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-22-2017, 01:13 PM Thread Starter
Junior Member
 
techchef's Avatar
 
Join Date: Jan 2017
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
My 2007 Impala

I have a 2007 Chevrolet Impala LTZ. I bought it used. I can not seem to get the radio to switch over to XM radio. I have the antenna on my roof, and the trunk has the XM receiver (or what seems to be)...I have it activated on a 2 month trial basis and nothing comes through..I push Band and it goes between AM and FM.

Linked below is a picture of the car (you can see the XM antenna)

and
The XM receiver that is in my trunk

Last edited by techchef; 01-22-2017 at 01:33 PM.
techchef is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 01-22-2017, 01:31 PM
Senior Member
 
Revo2Maxx2016's Avatar
 
Join Date: Aug 2016
Location: Northwest USA
Posts: 539
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)
Thanks: 5
Thanked 88 Times in 87 Posts
Wonder if your car had the unit replaced with one that isnt xm compatible? Does your unit have the cat button above eject?
Should be pressing the band button to get to xm stations. Did you look to see if there was a way to turn it on or off? Any after market wiring done like after market amps?

Sent from my VS880 using Tapatalk

It isn't what you Drive that matters, It is how you drive it.

James
Revo2Maxx2016 is online now  
post #3 of (permalink) Old 01-22-2017, 01:35 PM
Super Moderator
 
jtrosky's Avatar
 
Join Date: Jun 2013
Location: West Grove, PA
Posts: 10,302
Mentioned: 24 Post(s)
Tagged: 0 Thread(s)
Quoted: 273 Post(s)
Thanks: 961
Thanked 1,995 Times in 1,522 Posts
How did you get the XM ID to activate it? Did it show on the radio display (it should have). If the radio display showed the XM ID, then the radio is definitely XM-compatible. If you had to read the XM ID off of the XM tuner in the trunk, then you probably don't have the correct radio installed (for whatever reason).

Sent from my A1160 using Tapatalk
jtrosky is offline  
 
post #4 of (permalink) Old 01-22-2017, 01:36 PM Thread Starter
Junior Member
 
techchef's Avatar
 
Join Date: Jan 2017
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Revo2Maxx2016 View Post
Wonder if your car had the unit replaced with one that isnt xm compatible? Does your unit have the cat button above eject?
Should be pressing the band button to get to xm stations. Did you look to see if there was a way to turn it on or off? Any after market wiring done like after market amps?

Sent from my VS880 using Tapatalk
I do have a cat button above eject...Now that you are saying about that-there are wires, under my backseat-when i flip it up-they are cut, but they are thick as hell, and are ground wires. When I push CAT it says XM Feature. But when I push Band it goes from FM to AM...I do have XM favorites on my favorite list-but none work.
techchef is offline  
post #5 of (permalink) Old 01-22-2017, 01:37 PM Thread Starter
Junior Member
 
techchef's Avatar
 
Join Date: Jan 2017
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by jtrosky View Post
How did you get the XM ID to activate it? Did it show on the radio display (it should have). If the radio display showed the XM ID, then the radio is definitely XM-compatible. If you had to read the XM ID off of the XM tuner in the trunk, then you probably don't have the correct radio installed (for whatever reason).

Sent from my A1160 using Tapatalk
I used my VIN instead-it has an activation feature through Sirius XM using the VIN
techchef is offline  
post #6 of (permalink) Old 01-22-2017, 01:38 PM Thread Starter
Junior Member
 
techchef's Avatar
 
Join Date: Jan 2017
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by jtrosky View Post
How did you get the XM ID to activate it? Did it show on the radio display (it should have). If the radio display showed the XM ID, then the radio is definitely XM-compatible. If you had to read the XM ID off of the XM tuner in the trunk, then you probably don't have the correct radio installed (for whatever reason).

Sent from my A1160 using Tapatalk
And-When I talked with someone from SiriusXM they gave me my radio ID-and its LAWUN08W-which is the last digits on the sticker in the trunk unit.
techchef is offline  
post #7 of (permalink) Old 01-22-2017, 01:44 PM
Super Moderator
 
jtrosky's Avatar
 
Join Date: Jun 2013
Location: West Grove, PA
Posts: 10,302
Mentioned: 24 Post(s)
Tagged: 0 Thread(s)
Quoted: 273 Post(s)
Thanks: 961
Thanked 1,995 Times in 1,522 Posts
So you can't get the XM radio ID to show on the radio display? You should be able to. If you can't even see Radio ID on the radio screen then it sounds like there might be something wrong with the radio - or the radio isn't communicating with the XM radio in the trunk for some reason... It sounds like you have the correct radio though. Strange.

Pressing the Band button should definitely take you to the XM tuner - even if not activated (that's how you get your XM radio ID - by switching to the XM band before activated).

Sent from my A1160 using Tapatalk
jtrosky is offline  
post #8 of (permalink) Old 01-22-2017, 01:50 PM Thread Starter
Junior Member
 
techchef's Avatar
 
Join Date: Jan 2017
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by jtrosky View Post
So you can't get the XM radio ID to show on the radio display? You should be able to. If you can't even see Radio ID on the radio screen then it sounds like there might be something wrong with the radio - or the radio isn't communicating with the XM radio in the trunk for some reason... It sounds like you have the correct radio though. Strange.

Pressing the Band button should definitely take you to the XM tuner - even if not activated (that's how you get your XM radio ID - by switching to the XM band before activated).

Sent from my A1160 using Tapatalk
That is correct. Unable to access my ID on the radio. Bought the car used-and chevy wants 125.00 to just look at it-plus w/e it costs to fix it
techchef is offline  
post #9 of (permalink) Old 01-22-2017, 01:55 PM
Senior Member
 
Revo2Maxx2016's Avatar
 
Join Date: Aug 2016
Location: Northwest USA
Posts: 539
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)
Thanks: 5
Thanked 88 Times in 87 Posts
IT almost sounds like someone has put in a Aftermarket system in your car in the past. THe big wires you were talking about may have been for the Aftermarket Amp.. So it could be that the person that did the install didn't do it nicely and may have bypassed your extra wiring for your cars XM...

You may want to look in the trunk make sure the plug is plugged in. Also look behind the radio and make sure all is connected back... It could be that the person that did the install in the past cut out the wiring. Then the person to make it work only got the wiring for the normal radio... Sadly not everyone is kind when doing installs and don't do them to make sure they can replace stock radio back to factory specs when they want to sale the car....

James

It isn't what you Drive that matters, It is how you drive it.

James
Revo2Maxx2016 is online now  
post #10 of (permalink) Old 01-22-2017, 02:06 PM
Senior Member
 
Revo2Maxx2016's Avatar
 
Join Date: Aug 2016
Location: Northwest USA
Posts: 539
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)
Thanks: 5
Thanked 88 Times in 87 Posts
Sorry having computer issues. That is only half my answer lol.... For your radio to XM there should be 5 wires running between them...

Left Audio + Brown/White
Left Audio - Dark Green
Right Audio + Dark Green/White
Right Audio - Grey/Black

Another Dark Green is GMLAN Low Speed data
__________________________________________________ ____________
Then on the XM there should be Red/White for power
Black/White for ground
Also plugged in should be the Coax for the antenna.

James

It isn't what you Drive that matters, It is how you drive it.

James
Revo2Maxx2016 is online now  
post #11 of (permalink) Old 01-22-2017, 02:15 PM Thread Starter
Junior Member
 
techchef's Avatar
 
Join Date: Jan 2017
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Revo2Maxx2016 View Post
Sorry having computer issues. That is only half my answer lol.... For your radio to XM there should be 5 wires running between them...

Left Audio + Brown/White
Left Audio - Dark Green
Right Audio + Dark Green/White
Right Audio - Grey/Black

Another Dark Green is GMLAN Low Speed data
__________________________________________________ ____________
Then on the XM there should be Red/White for power
Black/White for ground
Also plugged in should be the Coax for the antenna.

James
I'll have to have a look at that then thanks!
techchef is offline  
post #12 of (permalink) Old 01-22-2017, 02:22 PM
Senior Member
 
Revo2Maxx2016's Avatar
 
Join Date: Aug 2016
Location: Northwest USA
Posts: 539
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 73 Post(s)
Thanks: 5
Thanked 88 Times in 87 Posts
Behind your radio you could have plugs like this and maybe they cut them out and only replaced the ones that make the radio work...



Also the wires would be twisted together so it would be not to hard to find the data Dark Green from the other one related to signal

It isn't what you Drive that matters, It is how you drive it.

James
Revo2Maxx2016 is online now  
post #13 of (permalink) Old 01-25-2017, 02:22 PM Thread Starter
Junior Member
 
techchef's Avatar
 
Join Date: Jan 2017
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
Took radio out-checked wires-No go...







techchef is offline  
post #14 of (permalink) Old 01-25-2017, 02:55 PM
Senior Member
 
NY13LTZ's Avatar
 
Join Date: Oct 2016
Location: Putnam County,NY
Posts: 245
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Thanks: 3
Thanked 27 Times in 24 Posts
techchef, I am no electronics wiz but if it turns out your radio is bad I have the factory stock radio which I removed from my 13 LTZ I'd be glad to give to a fellow forum member. Also just a quick note here, Jtrosky, and myself, and others have been upgrading our radios to the Rosen GM PD1010 radios with nav. They can be found on eBay from a seller called Memory-U. Usually around $150.00 for radio, Bose harness, and GPS antenna. Search "Rosen" in the forums and the thread should be listed.
NY13LTZ is offline  
The Following 2 Users Say Thank You to NY13LTZ For This Useful Post:
techchef (01-27-2017)
post #15 of (permalink) Old 01-25-2017, 03:02 PM Thread Starter
Junior Member
 
techchef's Avatar
 
Join Date: Jan 2017
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by NY13LTZ View Post
techchef, I am no electronics wiz but if it turns out your radio is bad I have the factory stock radio which I removed from my 13 LTZ I'd be glad to give to a fellow forum member. Also just a quick note here, Jtrosky, and myself, and others have been upgrading our radios to the Rosen GM PD1010 radios with nav. They can be found on eBay from a seller called Memory-U. Usually around $150.00 for radio, Bose harness, and GPS antenna. Search "Rosen" in the forums and the thread should be listed.
Much appreciated-I contacted a friend at Chevy and waiting to hear back from them-seeing if its something obvious i am missing...If it comes down to being a shit radio-I may take you up on that offer...
techchef is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Jeff gordon #24-2007 impala ss cot-owners elite-1 of 2007-1:24-see description RSS Bot Impala Diecast Toys Cars on eBay 0 05-12-2014 03:00 PM
Jeff gordon #24-2007 impala ss cot-owners elite-1 of 2007-1:24-see description RSS Bot Impala Diecast Toys Cars on eBay 0 05-09-2014 02:10 PM
Jeff gordon #24-2007 impala ss cot-owners elite-1 of 2007-1:24-see description RSS Bot Impala Diecast Toys Cars on eBay 0 05-06-2014 02:50 PM
jeff gordon #24 dupont 2007 impala ss cot owners elite. 1 of 2007 RSS Bot Impala Diecast Toys Cars on eBay 0 05-11-2013 05:50 PM
NASCAR~MA 2007 1:24~ #29 Kevin Harvick 2007 Impala SS COT~MINT IN BOX RSS Bot Impala Diecast Toys Cars on eBay 0 11-17-2012 12:50 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome