2010 impala rough ride - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Performance and Technical > Chevy Impala 8th Gen Discussion > 8th Gen Suspension

8th Gen Suspension Springs, Shocks and Brakes.

Reply
 
LinkBack Thread Tools Display Modes
Old 01-29-2012, 08:46 PM   #1 (permalink)
Junior Member
 
y2kpa2's Avatar
 
Join Date: Jan 2012
Location: The land of discontent
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
2010 impala rough ride

2010 impala lt fleet build


hello all i am new to this partciular forum i will not bother you all with all the details of problems i have had since buying my 2010 impala in september 2011 however the car rides like crap every bump every crack in the road you can feel and some times it beats your head against the head rest just driving over manhole covers on street.. it has 37,456 on it right now. have had it to dealer several times and last time they found real light paint over spray on driver rear strut and claim it has been wrecked and will not talk to me anymore but looking at the structure underneath and behind trunk carpet if it was it was no more than cosmetic but i am wondering if the tires could be the problem and what would be the recomended tire above the good year integrity o.e. tires on it now? the dealer that i bought it from was not the dealer that has preformed work they did fix a few of my concerens though.

thank you, Eric


Last edited by y2kpa2; 01-29-2012 at 09:14 PM..
y2kpa2 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-29-2012, 09:17 PM   #2 (permalink)
Junior Member
 
y2kpa2's Avatar
 
Join Date: Jan 2012
Location: The land of discontent
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
If any one has any insight it would be appreaciated.....thank you

__________________
You can't always get what you want
y2kpa2 is offline   Reply With Quote Quick reply to this message
Old 01-29-2012, 11:09 PM   #3 (permalink)
Guest
Guest
 
Guest's Avatar
 
Posts: n/a
Have u tried goin back to the dealer u bought it from?

  Reply With Quote Quick reply to this message
Old 01-29-2012, 11:11 PM   #4 (permalink)
Senior Member
 
Hersbird's Avatar
 
Join Date: Dec 2010
Posts: 290
Thanks: 0
Thanked 1 Time in 1 Post
We might need a little more info. Also this would be better asked in the 8th generation forum and there is specifically a suspension subforum there. Do you have the stock size wheels? It shouldn't be that stiff of a ride unless you are used to old caddys or something. There cars if anything ride pretty soft. Now if you are running 20 inch wheels or something. I also don't see how damage would affect it unless a strut is bent and not moving. If that's the case a new strut would fix that.

Hersbird is offline   Reply With Quote Quick reply to this message
Old 01-30-2012, 10:27 AM   #5 (permalink)
Junior Member
 
y2kpa2's Avatar
 
Join Date: Jan 2012
Location: The land of discontent
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
thats what i hear that they are supposed to ride real nice it has rpo FE1 and no binding of the struts. and yes i am an old buick guy i had a W body regal and recently a park ave but never any caddys.....yet . the rear passenger tire is worn on both edges that is where the trailing arm was replaced the first time i had to the local dealer. i had a guy at work who has worked in and owned his own shops through out town since the 1960's very smart man, drive it and the only thing he asked me when he brought it back was if i had air shocks on the back which it does not but thats what it feels like overinflated air shocks tire pressure is around 32-35 psi all 4 the O.E. tires good year integrity say 45 max and any thing less than what i have in them they look flat

__________________
You can't always get what you want
y2kpa2 is offline   Reply With Quote Quick reply to this message
Old 01-31-2012, 12:31 PM   #6 (permalink)
Senior Member
 
ChevroletCustomerService's Avatar
 
Join Date: Nov 2010
Posts: 872
Thanks: 1
Thanked 51 Times in 39 Posts
Quote:
Originally Posted by y2kpa2 View Post
thats what i hear that they are supposed to ride real nice it has rpo FE1 and no binding of the struts. and yes i am an old buick guy i had a W body regal and recently a park ave but never any caddys.....yet . the rear passenger tire is worn on both edges that is where the trailing arm was replaced the first time i had to the local dealer. i had a guy at work who has worked in and owned his own shops through out town since the 1960's very smart man, drive it and the only thing he asked me when he brought it back was if i had air shocks on the back which it does not but thats what it feels like overinflated air shocks tire pressure is around 32-35 psi all 4 the O.E. tires good year integrity say 45 max and any thing less than what i have in them they look flat
Welcome to the forum, Eric! I'm sorry to read about your frustrations, and I wanted to quickly jump in to let you know I would be happy to investigate further on your behalf if you direct message me with details (VIN/dealership/name/address). The community members here are extremely helpful as well, so I'm hoping the issues are resolved quickly. Please continue to keep us updated!

Best,

Katie
Chevrolet Customer Service

ChevroletCustomerService is online now   Reply With Quote Quick reply to this message
Old 01-31-2012, 01:21 PM   #7 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,656
Thanks: 516
Thanked 1,192 Times in 788 Posts
Well, for starters the goodyears are notorious for being total crap, in every measurable way. But I haven't driven one of these cars yet that I would call smooth, regardless of the tires, and I maintain 6 of them.

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Old 01-31-2012, 01:33 PM   #8 (permalink)
Guest
Guest
 
Guest's Avatar
 
Posts: n/a
you should drive mine king

  Reply With Quote Quick reply to this message
Old 01-31-2012, 05:38 PM   #9 (permalink)
Administrator

 
retiredpauly's Avatar
 
Join Date: Jan 2012
Location: Southern Alberta Canada
Posts: 5,972
Thanks: 622
Thanked 1,169 Times in 660 Posts
I might try going to a dealer and getting a used one and driving that and make that comparison. Or better yet taking a new one out for a test drive and seeing there.
I think that will give you a bit of insight as to what you have and where it falls down.
FWIW

Paul

retiredpauly is offline   Reply With Quote Quick reply to this message
Old 02-01-2012, 04:47 AM   #10 (permalink)
TSS
Administrator

 
TSS's Avatar
 
Join Date: Mar 2010
Location: Michigan
Posts: 8,873
Thanks: 541
Thanked 958 Times in 525 Posts
1. I would lower pressure to 32, unless you have the 16s, then 30 and try it even if the tires look "flat" to you.

2. Air shocks, I am still pointing towrd those even though you don't think that is the issue.

3. King: My 09 SS is smooth, really. And you know my former points of comparisons for past vehicles. Caddy smooth, no. But not rough or hard in any way, particularly with my winter 16s on it. Definitely harder with the stock 18s. But.... I do have excellent tires on it - and agree that Integrities suck on almost every level.,,including ride quality.

__________________
2009 Impala SS (sold 3/2012);
2010 Buick Enclave CXL;
2010 Lincoln MKS AWD Twin Turbo, Livernois Motor Sports tuned, K&N Typhoon CAI, 0-60 in 4.20 seconds , 1/4 mile 12.80 @ 104 MPH



"Trying Times Are Not a Good Time To Quit Trying"
TSS is online now   Reply With Quote Quick reply to this message
Old 02-01-2012, 05:30 AM   #11 (permalink)
Guest
Guest
 
Guest's Avatar
 
Posts: n/a
Mine is smooth......not Lincoln rock you to sleep smooth but still smooth.....And our roads are bumpy

  Reply With Quote Quick reply to this message
Old 02-01-2012, 09:59 AM   #12 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,656
Thanks: 516
Thanked 1,192 Times in 788 Posts
The struts are probably shot on all of mine, but regardless they are still rougher than the 7th gens.

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Old 02-06-2012, 09:10 PM   #13 (permalink)
Junior Member
 
y2kpa2's Avatar
 
Join Date: Jan 2012
Location: The land of discontent
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
so the goodyears are a possible culprit of my problems have yet to do anything have had 4 birthdays in my family oldest son my daughter my dad and my wife all between 1-29 and 2-8 not that that is relavent to an automotive forum i will reset the tire pressure to 30 tomorrow and try that. i still have to hear back from the guy at work he has no awnser as of yet and he worked on everybody's car here in town for the last 40 years and is usally a great source of automotive info. it just pisses me off i had a car i liked but rode like crap also i put all four struts/shocks and even z rated kuhmo tires all did not help,when i had the old one aligned it would last for about a week and first pothole i hit it was back out of whack so that is one of a few reasons i wanted a new car which is why i bought my impala. i had rented one for me and wife to go tennesee and loved the car and decided i had to have one of my own

__________________
You can't always get what you want
y2kpa2 is offline   Reply With Quote Quick reply to this message
Old 02-20-2012, 11:05 AM   #14 (permalink)
Junior Member
 
Falconjohnd's Avatar
 
Join Date: Feb 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mine rides like crap too!

Bought a 2009 Impala SS with 33K on it and now it has just shy of 36K. Goes to show how much I drive it because I like it so much. My 98 GTP with 128K rides better. Brought it back to the dealer I bought it from and they told me there was nothing wrong with it. That's how these cars ride. WTF are you serious? Brought it to another dealer and the told me there was a bulletin on the joice bumpers. They replaced them. Car rode "better" but still not great and now I feel as if the ride has regressed back to what it was. I have the stock 18" rims on it with brand new Dunlops that the dealer put on before they sold me the car. Don't remember which ones they are. But I have to tell you if you hit a seam or a small pothole going around a turn..... Hold on man. Really not happy with this car at all. Going to have my mechanic look at it tomorrow. Anybody else got anything?

Falconjohnd is offline   Reply With Quote Quick reply to this message
Old 02-21-2012, 05:07 PM   #15 (permalink)
Junior Member
 
Falconjohnd's Avatar
 
Join Date: Feb 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Let a mechanic look at it today. I went under with him. Says struts are weak and plates should be changed too. 36K? Anybody else aware of premature strut wearout on these?

Falconjohnd is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
07 Impala LT rough idle 1impala1 Chevy Impala 8th Gen Discussion 7 05-22-2014 08:12 PM
Killer ride 64 impala low rider chromed out ride RSS Bot Impala Diecast Toys Cars on eBay 0 05-05-2011 12:11 PM
2010 Impala Runs Rough Intermittently ScottABarton Mechanical and Electrical Problems 0 10-27-2010 03:35 PM
car rough idle for a second!!!!!WTF!!!! lopez Chevy Impala 7th Gen Discussion 11 09-18-2010 04:17 AM
Rough Idle 1stCaprice Chevy Caprice 7 06-25-2010 11:51 AM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.