Camshaft Actuator Solenoid (2008 LS 3.5L flex K) - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Performance and Technical > Chevy Impala 8th Gen Discussion > 8th Gen Engine Performance

Reply
 
LinkBack Thread Tools Display Modes
Old 09-25-2013, 05:37 PM   #1 (permalink)
Member
 
Ray2138's Avatar
 
Join Date: May 2012
Location: NC/VA
Posts: 32
Thanks: 3
Thanked 2 Times in 2 Posts
Camshaft Actuator Solenoid (2008 LS 3.5L flex K)

Started my car this morning and out of no where , my CEL came on. I plugged up my OBDII , and it gave me a "P0010" code. Which came to be "Camshaft Position (CMP) actuator solenoid control circuit ". Im not sure exactly where this actuator is located, or how hard it would be to access and change it if possible. I have yet to find anybody else with the same problem yet with theirs. ANY ideas or input would be greatly appreciated.

Ray2138 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-26-2013, 10:47 AM   #2 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,658
Thanks: 517
Thanked 1,202 Times in 791 Posts
It has come up a couple times here, but it isn't common. The actuator is located on the front of the block where the camshaft goes in. Directly under the PS pulley.

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Old 09-26-2013, 03:06 PM   #3 (permalink)
Member
 
Ray2138's Avatar
 
Join Date: May 2012
Location: NC/VA
Posts: 32
Thanks: 3
Thanked 2 Times in 2 Posts
I swear man you are a life saver!!!! I look forward to your responses on my questions. I figured out earlier today at work that the piece I was looking at was the cam actuator. I just needed the confirmation. So now it's finding the part and figuring out can I do it myself .

Ray2138 is offline   Reply With Quote Quick reply to this message
Old 09-26-2013, 05:00 PM   #4 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,658
Thanks: 517
Thanked 1,202 Times in 791 Posts
No problem, wish I could help further, but I have not had to replace one of those yet.

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Old 09-26-2013, 11:11 PM   #5 (permalink)
Member
 
Ray2138's Avatar
 
Join Date: May 2012
Location: NC/VA
Posts: 32
Thanks: 3
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by kingnutin View Post
No problem, wish I could help further, but I have not had to replace one of those yet.
It's looks fairly easy like four screws and a plug. Ill let you know how it turns out.

Ray2138 is offline   Reply With Quote Quick reply to this message
Old 09-27-2013, 06:56 AM   #6 (permalink)
Member
 
Ray2138's Avatar
 
Join Date: May 2012
Location: NC/VA
Posts: 32
Thanks: 3
Thanked 2 Times in 2 Posts
Checking it out the morning. when I unplugged the connector, to check it and the wire is frayed. It was rubbing against the serpentine belt. So I may be just looking at a plug connector .

Ray2138 is offline   Reply With Quote Quick reply to this message
Old 09-27-2013, 11:21 AM   #7 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,658
Thanks: 517
Thanked 1,202 Times in 791 Posts
That would be much easier, and cheaper! I bet that's it.

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Old 09-27-2013, 08:33 PM   #8 (permalink)
Member
 
Ray2138's Avatar
 
Join Date: May 2012
Location: NC/VA
Posts: 32
Thanks: 3
Thanked 2 Times in 2 Posts
So I spliced the wire together and cut the light off with my obdII reader. Everything is ok ill just have to order another plug connector. ALSO if the actuator goes bad it will effect how the tranny shift . I didn't believe if but it does. it gives it that hard stiff snatch into gear as they are changing. I thought my tranny was messed up again so I took it back to the place that rebuilt it. And that's when I found out that it effects it. And I also found out my oil pressure sending unit circuit is bad or the unit it self is bad .

Ray2138 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://www.impalaforums.com/8th-gen-engine-performance/410393-camshaft-actuator-solenoid-2008-ls-3-5l-flex-k.html
Posted By For Type Date
8th Gen Engine Performance on Chevy Impala Forums | BoardReader This thread Refback 10-22-2013 10:36 PM

Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 Impala LT Flex Fuel prodigo04 Chevy Impala 8th Gen Discussion 12 02-13-2012 01:57 PM
Chevrolet : Impala LT FLEX FUEL 2008 CHEVY IMPALA LT FLEX FUEL SS WHEELS WITH ONLY 38 RSS Bot eBay Cars For Sale: Impala 0 12-18-2011 10:52 PM
Chevrolet : Impala LS Flex Fuel Chevy Flex Fuel LS OnStar Cruise 55k Miles Amber Bron RSS Bot eBay Cars For Sale: Impala 0 09-16-2011 12:00 PM
Camshaft ?????? kobiewhite 8th Gen Engine Performance 13 08-02-2011 09:32 AM
2008 Impala Driver Rear Actuator Replacement HELP! eugeneo Automotive Discussion 0 04-22-2011 12:10 PM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.