Strange p0171 and p0174 codes - Chevy Impala Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-31-2017, 05:05 AM Thread Starter
Junior Member
 
eray's Avatar
 
Join Date: Feb 2015
Location: Whitsett, NC
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 2
Thanked 3 Times in 2 Posts
Strange p0171 and p0174 codes

2012 LTZ 3.6 Both codes have been intermittent since 80,00 miles. Dealer replaced gas cap and originally helped. Has never failed inspection and runs great. Now with 140,000 miles light is always on except when completely full of gas. Comes back on after using about 1/8 tank and stays on till next fill up. Checked all hoses and cleaned maf sensor , changed purge canister. Is there a vent or something that could be wrong with the filler neck ? Baffled!!
eray is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 05-31-2017, 07:33 AM
Senior Member
 
sheila's Avatar
 
Join Date: Sep 2013
Posts: 959
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 290
Thanked 234 Times in 178 Posts
Really need to look at short and long term fuel trims. If trims are high positive at idle and try to normalize at ~2500rpm, indicates a vacuum leak. If trims are high positive at idle and go even higher at ~2500rpm, indicates a fuel system/delivery problem.
sheila is online now  
post #3 of (permalink) Old 05-31-2017, 12:47 PM Thread Starter
Junior Member
 
eray's Avatar
 
Join Date: Feb 2015
Location: Whitsett, NC
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 2
Thanked 3 Times in 2 Posts
I can't give up the car right now long enough to get to a shop that can run a fuel trim analysis. I did notice that the new vapor purge solenoid starts clicking continuously about 10 seconds after start up.
eray is offline  
 
post #4 of (permalink) Old 05-31-2017, 12:49 PM
Super Moderator
 
jtrosky's Avatar
 
Join Date: Jun 2013
Location: West Grove, PA
Posts: 10,566
Mentioned: 33 Post(s)
Tagged: 0 Thread(s)
Quoted: 342 Post(s)
Thanks: 964
Thanked 2,050 Times in 1,571 Posts
Quote:
Originally Posted by eray View Post
I can't give up the car right now long enough to get to a shop that can run a fuel trim analysis. I did notice that the new vapor purge solenoid starts clicking continuously about 10 seconds after start up.
That does not sound normal at all... Maybe you got a bad part - it happens. Or there is something else causing it to behave like that...

Sent from my Hi10 pro using Tapatalk
jtrosky is online now  
post #5 of (permalink) Old 05-31-2017, 07:46 PM
Senior Member
 
sheila's Avatar
 
Join Date: Sep 2013
Posts: 959
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 290
Thanked 234 Times in 178 Posts
Got a friend with a scan tool that'll read fuel trims? I think most parts stores will just read your lean codes. Did you swap out the evap. emissions component underhood or at the drivers lr?

Last edited by sheila; 06-01-2017 at 08:28 AM.
sheila is online now  
post #6 of (permalink) Old 06-01-2017, 06:31 PM Thread Starter
Junior Member
 
eray's Avatar
 
Join Date: Feb 2015
Location: Whitsett, NC
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 2
Thanked 3 Times in 2 Posts
Switched out the vapor purge solenoid under the hood, the new one clicked all the time . This evening , I put the old one back on and filled the car up with gas, the old one does not click all the time and the light is still on. I am trying to think if someone I know has the fuel trim program on their scanner, my two do not. This whole thing is so baffling because the engine runs perfect. May end up taking it back to the dealer, the first time we mentioned it may be a "real problem" their first response was , we really hate it when this happens to a car this new but still runs good. Could it possibly be the upper intake manifold gasket, does this cause this kind of issue?
eray is offline  
post #7 of (permalink) Old 06-01-2017, 06:59 PM
Senior Member
 
sheila's Avatar
 
Join Date: Sep 2013
Posts: 959
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 290
Thanked 234 Times in 178 Posts
^ Uim gasket is possible but doubtful on a '12. If it's not sealing, it'd be a vacuum leak like a faulty vac. hose. Has the uim ever been removed to your knowledge? Can you return the clicking underhood purge valve solenoid for another? May check/suspect the evap. component in the lr wheelwell.
sheila is online now  
post #8 of (permalink) Old 06-01-2017, 07:58 PM
Member
 
Bill58's Avatar
 
Join Date: Apr 2017
Location: Frederick, MD
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Thanks: 2
Thanked 10 Times in 10 Posts
Garage
Pretty sure the fuel level needs to be above 15% and below 85% to run evaporative emissions monitor, EVAP. Also a open purge solenoid can cause a lean condition if its open without the ecm commanding it to open, itís basically a vacuum leak. You need to find out if and/or why the purge solenoid is turning on.
Bill58 is offline  
post #9 of (permalink) Old 06-02-2017, 06:07 PM Thread Starter
Junior Member
 
eray's Avatar
 
Join Date: Feb 2015
Location: Whitsett, NC
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 2
Thanked 3 Times in 2 Posts
What component is under the left rear wheel well?
eray is offline  
post #10 of (permalink) Old 06-02-2017, 06:12 PM
Member
 
Bill58's Avatar
 
Join Date: Apr 2017
Location: Frederick, MD
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Thanks: 2
Thanked 10 Times in 10 Posts
Garage
Vapor Canister Vent Valve / Solenoid
Bill58 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
P0171 mcar585 Automotive Discussion 0 08-16-2016 02:59 AM
P0171 mcar585 Automotive Discussion 0 08-15-2016 06:47 PM
P0171 mcar585 Automotive Discussion 0 08-15-2016 05:02 PM
P0171 mcar585 Automotive Discussion 0 08-15-2016 04:24 PM
Please help me with p0171 !! jgbride Chevy Impala 7th Gen Discussion 7 04-01-2016 07:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome