Service Traction Control - Chevy Impala Forums
8th Gen Drivetrain Transmissions, clutches, and axles.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-06-2011, 10:39 AM Thread Starter
Senior Member
 
SPARTAN sui's Avatar
 
Join Date: May 2011
Location: Bottineau, ND
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Service Traction Control

Okay guys, I've been searching these forums about this issue because today my car threw out this error, "Service Traction Control". It comes on about 1 minute or so that my car has been running, it will chime a few times, and the check engine light will also light up, along with the traction light naturally.

However I'm not getting the ABS light like a lot of people have been reporting.

One thing I should mention, and I think it might be linked, but I have no idea because I'm not much of a car guy. Anyways, it's been pretty cold, about 10*F, and I decided to go through a touchless car wash because my car was pretty dirty, well probably not the brightest idea to do when it's this cold. But anyways, I went through that, then drove about 160 miles to my destination. I didn't have a single light or issue on the trip down, however this morning it started with the service traction control issue.

I tried turning my engine off, and back on, but that didn't do anything. And it kept chiming and warning me on my way to the meeting I'm currently in.

The only other thing is I did get two new front tires installed by Tires Plus a couple of weeks ago.

I'll let you know if I get this message when I head back to where I'm staying. But if I could get some input on what may be wrong, I'd much appreciate it!


I do have powertrain warranty also, until February and my car only has 56,500 miles on it.

Thanks guys!


2007 Impala SS traded for 2011 Camaro 2LT
SPARTAN sui is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-06-2011, 12:47 PM
Senior Member
 
AlfredoSmith's Avatar
 
Join Date: Jan 2010
Posts: 2,468
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 7 Times in 7 Posts
What is a touchless car wash? is it high pressure or something?

I would start by inspecting the ABS connections on each wheel (realizing that a bad connection would probablly also throw an ABS code).

Can you assess if your TC is actually working? I guess just by romping on it and trying to get a wheel spin... you should get a "TC engaged" message.

SPACE FOR RENT
AlfredoSmith is offline  
post #3 of (permalink) Old 12-06-2011, 03:29 PM
Impalaforums.com

 
Stephen's Avatar
 
Join Date: Sep 2011
Location: Kentucky
Posts: 3,526
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 7
Thanked 47 Times in 24 Posts
Touchless car wash is a high pressure wash.nothing touchs the car but water and soap...might have just got water in something or froze something up....Did you try turning the car off and then back on? sometimes it will go away when you do that. did the car wash have the undercarriage wash that shoots water into your rocker panels and all that?
Stephen is offline  
post #4 of (permalink) Old 12-06-2011, 04:14 PM Thread Starter
Senior Member
 
SPARTAN sui's Avatar
 
Join Date: May 2011
Location: Bottineau, ND
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
The car wash did have jets shoot under the car as you enter the wash, I know I didn't dry completely cause the wash already was letting someone in behind me, I got it dried for the most part, but had a few ice droplets on my hood and such.

I just got back to my GF's house and my car seemed to be running fine. I got the traction control message to come on after 2the minutes or so sitting in the parking lot. Check engine light was on from ignition. Doesn't go away. But as soon as I started going, the traction control message dissapeared, along with the light. It came back on when I was at a stop light and I was waiting little over a minute or two. But didn't come on the rest of the trip, which is a few miles. However check engine light is still on. Even when turning the car on and off. I also believe my car is idiling funny. I had it parked for awhile seeing if the TC light would come on, it didn't, but check engine light still was. when idiling it feels like it's dying down, comes back up, dies down a little, then comes back up. It just doesn't seem right to me, however I don't know much about vehicles, and I'm not sure if it's because it's only 30*F out.

I didn't want to try spinning out because I have new tires, it's not that slick out, and there is traffic everywhere. (Basically I know I'm going to make a lot of noise because I'll have to really get on it) I don't know the area so I have no idea where to go to try that. Maybe I'll get a chance to test it tomorrow morning. But now I'm more worried about my check engine light and what I think is a funny idle.

How do I inspect the ABS connections on the wheels? I have next to zero knowledge about this sort of thing. The ABS light is not illuminated however.

I made an appointment for Saturday at a dealership in this area, pretty much the earliest I could get in. Do you guys have an educated guesses on what I might expect? My powertrain warranty is still good.


2007 Impala SS traded for 2011 Camaro 2LT
SPARTAN sui is offline  
post #5 of (permalink) Old 12-06-2011, 04:21 PM
Impalaforums.com

 
Stephen's Avatar
 
Join Date: Sep 2011
Location: Kentucky
Posts: 3,526
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 7
Thanked 47 Times in 24 Posts
the check engine light is usually if not always something with the emissions...you could see what code it throws but the dealership will know alot more than them cheap ass scanners at autozone.
Stephen is offline  
post #6 of (permalink) Old 12-06-2011, 04:47 PM Thread Starter
Senior Member
 
SPARTAN sui's Avatar
 
Join Date: May 2011
Location: Bottineau, ND
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Hmm, alright. When they hook their scanner, I know just even looking at it can cost upwards of $100, do you know, or does anyone know if that's covered on powertrain warranty?


2007 Impala SS traded for 2011 Camaro 2LT
SPARTAN sui is offline  
post #7 of (permalink) Old 12-06-2011, 05:03 PM
Guest
Guest
 
Guest's Avatar
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
i may be wrong......but i believe powertrain only covers the engine and transmission
post #8 of (permalink) Old 12-06-2011, 05:32 PM
Impalaforums.com

 
Stephen's Avatar
 
Join Date: Sep 2011
Location: Kentucky
Posts: 3,526
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 7
Thanked 47 Times in 24 Posts
well if thats the case then you can stop by autozone or somewhere like that and have them see what code it throws....but whatever code it throws doesnt necessarily mean thats what needs to be fixed...know what im sayin...
Stephen is offline  
post #9 of (permalink) Old 12-06-2011, 07:02 PM Thread Starter
Senior Member
 
SPARTAN sui's Avatar
 
Join Date: May 2011
Location: Bottineau, ND
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I gotcha, I'll just let the dealership do their thing


2007 Impala SS traded for 2011 Camaro 2LT
SPARTAN sui is offline  
post #10 of (permalink) Old 12-07-2011, 10:22 AM
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,655
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 517
Thanked 1,225 Times in 803 Posts
Just get them to tell you ahead of time what will and will not be covered, if it's part of the powertrain warranty they will not charge diagnostics.

1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline  
post #11 of (permalink) Old 12-07-2011, 12:39 PM Thread Starter
Senior Member
 
SPARTAN sui's Avatar
 
Join Date: May 2011
Location: Bottineau, ND
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I hope it's covered. Yeah, the said they'll call me before they do any work that's not covered under warranty.

I received the TC message again this morning, but as soon as I started driving, it went away and didn't come on the rest of the trip. So it seems it only throws the error when it's been sitting and is parked?

Been doing a bit a of searching also, so when there's a solid check engine light, that doesn't mean there's currently an error, it means there was an error that needs to be cleared with a scanner before it goes away. Does that sound correct?

Maybe the rough idle is just in my head. >.< It does run fine otherwise...

3 more days to go, I hate waiting around for these things!


2007 Impala SS traded for 2011 Camaro 2LT
SPARTAN sui is offline  
post #12 of (permalink) Old 12-07-2011, 03:34 PM
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,655
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 517
Thanked 1,225 Times in 803 Posts
Typically, the CEL will turn itself off when an issue is resolved, if it's still on there is still a problem. I often avoid clearing a code when I fix something to see if it goes away, it usually does.

1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline  
post #13 of (permalink) Old 12-07-2011, 03:38 PM
Impalaforums.com

 
Stephen's Avatar
 
Join Date: Sep 2011
Location: Kentucky
Posts: 3,526
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 7
Thanked 47 Times in 24 Posts
yea, everytime i had a check engine light come on and i fixed the problem it went away without clearing it...It cleared itself...hopefully they give you some good news this weekend....
Stephen is offline  
post #14 of (permalink) Old 12-07-2011, 03:38 PM Thread Starter
Senior Member
 
SPARTAN sui's Avatar
 
Join Date: May 2011
Location: Bottineau, ND
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Mmkay, I'll keep you guys posted on what the dealership finds out. Thanks for the input guys.

I'll be keeping my too!


2007 Impala SS traded for 2011 Camaro 2LT
SPARTAN sui is offline  
post #15 of (permalink) Old 12-08-2011, 08:59 AM
Senior Member
 
AlfredoSmith's Avatar
 
Join Date: Jan 2010
Posts: 2,468
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 7 Times in 7 Posts
Does the TC sensor work off the same sensor as the ABS? If so, its the wire coming right off your wheel hub (just take off the wheel to inspect). It sounds like a connection may be getting pinched, or might be loose. When you check out the connection, inspect the wire to make sure there are no signs that its getting pinched. There shouldnt be anything interfering with it.

SPACE FOR RENT
AlfredoSmith is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  LinkBacks (?)
LinkBack to this Thread: http://www.impalaforums.com/8th-gen-drivetrain/304462-service-traction-control.html
Posted By For Type Date
Service Traction Control - Page 3 - Chevy Impala Forums This thread Refback 03-02-2015 04:38 PM
Service Traction Control Page 3 Chevy Impala Forums - Infoter.blg.lt This thread Refback 01-29-2015 11:59 AM
service traction control impala - forums post summary | BoardReader This thread Refback 12-31-2013 01:12 PM

Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 Impala - Service Traction Control jhager Autocare and Maintenance 5 02-25-2011 07:04 AM
Service ABS and Traction Control warnings! AlfredoSmith Chevy Impala 8th Gen Discussion 12 09-09-2010 05:01 AM
Service Traction Control System indyimpalass 7th Gen Drivetrain 16 05-12-2010 05:47 AM
Service Traction Control problem AKvsAR Chevy Impala 7th Gen Discussion 26 04-06-2010 06:53 AM
Traction control service light cfjames11 Autocare and Maintenance 3 12-07-2008 12:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome