Car hesitating when accelerating - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Performance and Technical > Chevy Impala 7th Gen Discussion > 7th Gen Engine Performance

Reply
 
LinkBack Thread Tools Display Modes
Old 08-09-2012, 10:58 AM   #1 (permalink)
Junior Member
 
biglo's Avatar
 
Join Date: Sep 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Car hesitating when accelerating

Hey guys, I have a 2005 chevy impala 3.4 base and I have a problem where I accelerate my car sort of hesitates, kinda jerking a bit. Like if going but it doesnt want to keep going. It normal happens between30 - 40 mph right on 35mph most of the times. Its really getting to me now I changed all spark plugs leads and I've changed my coils as well. Plus I changed the fuel filter. I wondering if it would be the ICM (ignition control module) or something like that. But any help would be appreciated.

biglo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-09-2012, 11:47 AM   #2 (permalink)
I eat brains... gimme brains!
 
pbNJ's Avatar
 
Join Date: Dec 2010
Location: South Jersey
Posts: 639
Thanks: 4
Thanked 25 Times in 21 Posts
I had the same problem a few years ago right after I did a tune up on my 3.4.. I brought into the stealership for a diagnosis and it turned out to be a bad #3 plug wire.. since I just replaced them w/ brand new stock wires, I put my old one back on and that fixed the problem.. I contacted ACDelco about my problem and they sent me another brand new #3 wire... never had the problem again

pbNJ is offline   Reply With Quote Quick reply to this message
Old 08-09-2012, 11:54 AM   #3 (permalink)
Carpe Diem


 
donmateo's Avatar
 
Join Date: Aug 2009
Location: Racine, WI
Posts: 18,411
Thanks: 1,761
Thanked 1,533 Times in 1,039 Posts
Send a message via MSN to donmateo Send a message via Skype™ to donmateo
What RPMs are you at with this? Are you flooring it?

Also....moved to 7th gen engine.

__________________
www.basilonestopshop.com
Basil One-Stop Shop BBM Channel: C00120B93
Basil One-Stop Shop BBM Customer Service Chat Available
donmateo is online now   Reply With Quote Quick reply to this message
Old 08-10-2012, 07:32 AM   #4 (permalink)
Senior Member
 
jrd0304's Avatar
 
Join Date: Aug 2009
Location: Cleveland, OH
Posts: 150
Thanks: 2
Thanked 5 Times in 3 Posts
Does it only happen when the car is at full temp? What kind of coils did you buy? Delcos or another OEM brand?

I feel your pain. I've been going through a similar situation myself in my 2003 3.4. Jerky, like the trans is acting up, but only at full temp. No check engine light, just an annoying, intermittent, seemingly harmless but still very aggravating jerk/hesitation on slight throttle when cruising. Comes and goes like the wind. Goes away when you give it more gas.

I've been chasing this ghost for a long time, at least a year maybe longer.

Long story short, I've been running two original factory coils on an engine w/188K, and one aftermarket OEM BWD coil. After doing a lot of what you've tried, (new plugs, new wires, new fuel filter, etc), I broke down and got three brand new AC Delco coils, and put them on last night. I am waiting to see if it goes away, it hasn't come back yet after a couple trips, but I'm still not positive the issue went away yet.

I've been reading some other forums, and many other makes/models have had DIS coil issues, but no check engine light since the problem isn't severe enough to exceed misfire counting in the PCM. It's almost like a bad coil won't throw a pending code or anything unless it's 110% fried up.

I will let you know if that helps me, not saying it will fix your issue, but it sounds like we're having similar problems.

jrd0304 is offline   Reply With Quote Quick reply to this message
Old 08-10-2012, 08:30 AM   #5 (permalink)
Senior Member
 
ChevroletCustomerService's Avatar
 
Join Date: Nov 2010
Posts: 867
Thanks: 1
Thanked 51 Times in 39 Posts
Biglo, I realize you're probably interested specifically in Do-It-Yourself advice, so I just wanted to jump into the thread quickly to let you know I'm available via direct message anytime if you would like me to research further on your behalf!

Best,

Katie
Chevrolet Customer Service

ChevroletCustomerService is offline   Reply With Quote Quick reply to this message
Old 08-10-2012, 11:06 AM   #6 (permalink)
Joe
Senior Member
 
Joe's Avatar
 
Join Date: Apr 2012
Location: Detroit
Posts: 848
Thanks: 87
Thanked 59 Times in 46 Posts
Quote:
Originally Posted by biglo View Post
Hey guys, I have a 2005 chevy impala 3.4 base and I have a problem where I accelerate my car sort of hesitates, kinda jerking a bit. Like if going but it doesnt want to keep going. It normal happens between30 - 40 mph right on 35mph most of the times. Its really getting to me now I changed all spark plugs leads and I've changed my coils as well. Plus I changed the fuel filter. I wondering if it would be the ICM (ignition control module) or something like that. But any help would be appreciated.
Changed the wires?

If you have a CEL or SES light on the dash, have the car scanned to see if is throwing a code.

Not sure how the Impala is setup, but I had a similar problem on my GMC pickup, turns out it was the fuel pump.

Other items I had to do periodically to the truck were cleaning the MAF and throttle body. May apply to the Impala as well.

__________________
** SOLD ** 2005 Impala - Base with a bunch of options / Debadged

1967 Camaro RS/SS L78 - Perpetual restoration project

2007 Trailblazer SS - Red Jewel

Joe is online now   Reply With Quote Quick reply to this message
Old 08-10-2012, 03:26 PM   #7 (permalink)
Back in Black
 
12ltz's Avatar
 
Join Date: Apr 2012
Location: Manassas or Suffolk,Va
Posts: 3,979
Thanks: 76
Thanked 167 Times in 129 Posts
My wife's 3.4 had a problem like this cleaned MAF and IAC and no more problem.

12ltz is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
95 SS starts hesitating Impala9596 Chevy Impala 6th Gen Discussion 7 07-09-2012 10:56 AM
Car dances a jig when accelerating tonyc712000 Chevy Impala 7th Gen Discussion 8 05-31-2012 08:31 AM
'96 4.3L Hesitating 1stCaprice Automotive Discussion 2 11-14-2011 03:24 AM
2003 9C1- throwing codes and hesitating HighwayLurker Chevy Impala 7th Gen Discussion 7 03-30-2009 07:37 AM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.