96 LT1 oil pump priming and initial break-in - Chevy Impala Forums

It appears you have not yet registered with our community. To register please click here...

Chevy Impala Forums

Go Back   Chevy Impala Forums > Performance and Technical > Chevy Impala 6th Gen Discussion > 6th Gen Engine Performance

Reply
 
LinkBack Thread Tools Display Modes
Old 02-27-2012, 12:25 AM   #1 (permalink)
Junior Member
 
78 'bu's Avatar
 
Join Date: Feb 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
96 LT1 oil pump priming and initial break-in

Just got a fresh rebuild on the LT1. I'm getting ready to fire her up this weekend. I've seen two different ways to prime the oil pump. One way is to pull the drive unit and build a tool to drive the pump (makes good sense). The other is to disconnect the coil and crank the starter (seems like i'd want oil pressure before turning the engine). Any experience with these methods? What's preferred? And what oil to use and what's the break-in procedure?

78 'bu is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-28-2012, 03:14 PM   #2 (permalink)
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,656
Thanks: 516
Thanked 1,192 Times in 788 Posts
I've always just used assembly lube on the moving parts, and just start the thing, no priming. Maybe fill the oil filter?

__________________
1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Traction Control engaging on initial launch AKvsAR Chevy Impala 7th Gen Discussion 12 09-14-2011 01:26 PM
Initial start up MSLogan1 Introductions & Welcome Forum 1 05-23-2011 05:51 AM
94 Caprice Classic Break Question. H-Town-Classic Automotive Discussion 3 10-11-2010 05:37 AM
Some Little Prick Tried To Break In My Car Last Night Bizkitss81 Chevy Caprice 3 08-12-2009 07:27 AM
Why is my 2001 Chevy Impala Idling @ 2500 - 3000 RPM at initial start up? Renee T Chevy Impala Discussion 0 04-16-2008 11:29 AM




Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.